summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorLiam <byteslice@airmail.cc>2023-10-08 17:32:32 +0200
committerLiam <byteslice@airmail.cc>2023-10-08 18:54:23 +0200
commit21bc2c14bc7408427a8b4851a7a3f15251f2afa8 (patch)
tree69597208c660a1af323b7e6dc5ff8e804e555682 /src/common/CMakeLists.txt
parentMerge pull request #11656 from liamwhite/recreate-surface-automatically (diff)
downloadyuzu-21bc2c14bc7408427a8b4851a7a3f15251f2afa8.tar
yuzu-21bc2c14bc7408427a8b4851a7a3f15251f2afa8.tar.gz
yuzu-21bc2c14bc7408427a8b4851a7a3f15251f2afa8.tar.bz2
yuzu-21bc2c14bc7408427a8b4851a7a3f15251f2afa8.tar.lz
yuzu-21bc2c14bc7408427a8b4851a7a3f15251f2afa8.tar.xz
yuzu-21bc2c14bc7408427a8b4851a7a3f15251f2afa8.tar.zst
yuzu-21bc2c14bc7408427a8b4851a7a3f15251f2afa8.zip
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 416203c59..8a1861051 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -189,6 +189,14 @@ if(ARCHITECTURE_x86_64)
target_link_libraries(common PRIVATE xbyak::xbyak)
endif()
+if (ARCHITECTURE_arm64 AND (ANDROID OR LINUX))
+ target_sources(common
+ PRIVATE
+ arm64/native_clock.cpp
+ arm64/native_clock.h
+ )
+endif()
+
if (MSVC)
target_compile_definitions(common PRIVATE
# The standard library doesn't provide any replacement for codecvt yet