summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorH Lohaus <hlohaus@users.noreply.github.com>2024-11-16 13:19:51 +0100
committerGitHub <noreply@github.com>2024-11-16 13:19:51 +0100
commit6ce493d4dfc2884832ff5b5be4479a55818b2fe7 (patch)
tree92e9efce62f7832ebe56969c120d8e92e75881a3 /setup.py
parentUpdate internet.py (diff)
downloadgpt4free-6ce493d4dfc2884832ff5b5be4479a55818b2fe7.tar
gpt4free-6ce493d4dfc2884832ff5b5be4479a55818b2fe7.tar.gz
gpt4free-6ce493d4dfc2884832ff5b5be4479a55818b2fe7.tar.bz2
gpt4free-6ce493d4dfc2884832ff5b5be4479a55818b2fe7.tar.lz
gpt4free-6ce493d4dfc2884832ff5b5be4479a55818b2fe7.tar.xz
gpt4free-6ce493d4dfc2884832ff5b5be4479a55818b2fe7.tar.zst
gpt4free-6ce493d4dfc2884832ff5b5be4479a55818b2fe7.zip
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 4 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index 48bbede9..b35f9754 100644
--- a/setup.py
+++ b/setup.py
@@ -13,8 +13,7 @@ INSTALL_REQUIRE = [
"aiohttp",
"brotli",
"pycryptodome",
- "curl_cffi>=0.6.2",
- "cloudscraper" # Cloudflare
+ "nest_asyncio",
]
EXTRA_REQUIRE = {
@@ -22,18 +21,10 @@ EXTRA_REQUIRE = {
"curl_cffi>=0.6.2",
"certifi",
"browser_cookie3", # get_cookies
- "PyExecJS", # GptForLove, Vercel
"duckduckgo-search>=5.0" ,# internet.search
"beautifulsoup4", # internet.search and bing.create_images
"brotli", # openai, bing
- # webdriver
- #"undetected-chromedriver>=3.5.5",
- #"setuptools",
- #"selenium-wire"
- # webview
- "pywebview",
"platformdirs",
- "plyer",
"cryptography",
"aiohttp_socks", # proxy
"pillow", # image
@@ -41,7 +32,8 @@ EXTRA_REQUIRE = {
"werkzeug", "flask", # gui
"fastapi", # api
"uvicorn", "nest_asyncio", # api
- "pycryptodome" # openai
+ "pycryptodome", # openai
+ "nodriver",
],
"image": [
"pillow",
@@ -60,12 +52,9 @@ EXTRA_REQUIRE = {
"plyer",
"cryptography"
],
- "openai": [
- "pycryptodome"
- ],
"api": [
"loguru", "fastapi",
- "uvicorn", "nest_asyncio"
+ "uvicorn",
],
"gui": [
"werkzeug", "flask",