summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2015-05-08 00:18:41 +0200
committerMattes D <github@xoft.cz>2015-05-08 00:18:41 +0200
commit237d8fa501501a8fab881d045fa4f1eee0e728b4 (patch)
treeae916b7f21ea456da862abeee338742d4c7bc6ac /CMakeLists.txt
parentMerge pull request #1949 from SafwatHalaby/burn (diff)
parentFixed inter-plugin calls. (diff)
downloadcuberite-237d8fa501501a8fab881d045fa4f1eee0e728b4.tar
cuberite-237d8fa501501a8fab881d045fa4f1eee0e728b4.tar.gz
cuberite-237d8fa501501a8fab881d045fa4f1eee0e728b4.tar.bz2
cuberite-237d8fa501501a8fab881d045fa4f1eee0e728b4.tar.lz
cuberite-237d8fa501501a8fab881d045fa4f1eee0e728b4.tar.xz
cuberite-237d8fa501501a8fab881d045fa4f1eee0e728b4.tar.zst
cuberite-237d8fa501501a8fab881d045fa4f1eee0e728b4.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 76b91e642..2bb780eba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -78,6 +78,9 @@ endif()
# The Expat library is linked in statically, make the source files aware of that:
add_definitions(-DXML_STATIC)
+# Let Lua use additional checks on its C API. This is only compiled into Debug builds:
+add_definitions(-DLUA_USE_APICHECK)
+
# Self Test Mode enables extra checks at startup
if(${SELF_TEST})
add_definitions(-DSELF_TEST)