summaryrefslogtreecommitdiffstats
path: root/lib/expat/CMakeLists.txt
diff options
context:
space:
mode:
authorTycho Bickerstaff <work.tycho@gmail.com>2013-12-22 16:21:34 +0100
committerTycho Bickerstaff <work.tycho@gmail.com>2013-12-22 16:21:34 +0100
commit1a9d93665f9f82ccd9054aa1c8e9c24f13776a91 (patch)
treee9572b3fdf1d47c0769a3d43d3fc4dfac68fd0dd /lib/expat/CMakeLists.txt
parentbasic threadsafe queue interface (diff)
parentUpdate GETTING-STARTED.md (diff)
downloadcuberite-1a9d93665f9f82ccd9054aa1c8e9c24f13776a91.tar
cuberite-1a9d93665f9f82ccd9054aa1c8e9c24f13776a91.tar.gz
cuberite-1a9d93665f9f82ccd9054aa1c8e9c24f13776a91.tar.bz2
cuberite-1a9d93665f9f82ccd9054aa1c8e9c24f13776a91.tar.lz
cuberite-1a9d93665f9f82ccd9054aa1c8e9c24f13776a91.tar.xz
cuberite-1a9d93665f9f82ccd9054aa1c8e9c24f13776a91.tar.zst
cuberite-1a9d93665f9f82ccd9054aa1c8e9c24f13776a91.zip
Diffstat (limited to 'lib/expat/CMakeLists.txt')
-rw-r--r--lib/expat/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/lib/expat/CMakeLists.txt b/lib/expat/CMakeLists.txt
index df9e8d57c..667804b9a 100644
--- a/lib/expat/CMakeLists.txt
+++ b/lib/expat/CMakeLists.txt
@@ -2,10 +2,15 @@
cmake_minimum_required (VERSION 2.6)
project (expat)
-include_directories ("${PROJECT_SOURCE_DIR}/../../src/")
-
file(GLOB SOURCE
"*.c"
)
+# add headers to MSVC project files:
+if (WIN32)
+ file(GLOB HEADERS "*.h")
+ set(SOURCE ${SOURCE} ${HEADERS})
+ source_group("Sources" FILES ${SOURCE})
+endif()
+
add_library(expat ${SOURCE})