summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authormadmaxoft <github@xoft.cz>2014-04-28 22:05:02 +0200
committermadmaxoft <github@xoft.cz>2014-04-28 22:05:02 +0200
commit0b16e6821ff475dca0539426ec403241170ce93d (patch)
treee272cae036cd9117e1d1f4cea3555c0c0d3aa748 /src/CMakeLists.txt
parentAdded the G1 root cert. (diff)
parentMerge pull request #940 from Howaner/GlobalFixes (diff)
downloadcuberite-0b16e6821ff475dca0539426ec403241170ce93d.tar
cuberite-0b16e6821ff475dca0539426ec403241170ce93d.tar.gz
cuberite-0b16e6821ff475dca0539426ec403241170ce93d.tar.bz2
cuberite-0b16e6821ff475dca0539426ec403241170ce93d.tar.lz
cuberite-0b16e6821ff475dca0539426ec403241170ce93d.tar.xz
cuberite-0b16e6821ff475dca0539426ec403241170ce93d.tar.zst
cuberite-0b16e6821ff475dca0539426ec403241170ce93d.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 67bb299db..900577526 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -57,6 +57,14 @@ if (NOT MSVC)
Entities/Pickup.h
Entities/Player.h
Entities/ProjectileEntity.h
+ Entities/ArrowEntity.h
+ Entities/ThrownEggEntity.h
+ Entities/ThrownEnderPearlEntity.h
+ Entities/ExpBottleEntity.h
+ Entities/ThrownSnowballEntity.h
+ Entities/FireChargeEntity.h
+ Entities/FireworkEntity.h
+ Entities/GhastFireballEntity.h
Entities/TNTEntity.h
Entities/ExpOrb.h
Entities/HangingEntity.h
@@ -123,6 +131,7 @@ if (NOT MSVC)
file(GLOB SOURCE
"*.cpp"
+ "*.h"
)
list(REMOVE_ITEM SOURCE "${PROJECT_SOURCE_DIR}/StackWalker.cpp" "${PROJECT_SOURCE_DIR}/LeakFinder.cpp")