summaryrefslogtreecommitdiffstats
path: root/src/OSSupport/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2015-01-24 09:27:55 +0100
committerMattes D <github@xoft.cz>2015-01-24 09:27:55 +0100
commitf91de20ca14725a41ea082b61a98477427c78528 (patch)
tree7925214f6faec943d0bdffc3c2706eed8fe744e9 /src/OSSupport/CMakeLists.txt
parentMerge pull request #1712 from UltraCoderRU/fix_coverity (diff)
parentcNetwork: Added self pointers to keep objects alive for callbacks. (diff)
downloadcuberite-f91de20ca14725a41ea082b61a98477427c78528.tar
cuberite-f91de20ca14725a41ea082b61a98477427c78528.tar.gz
cuberite-f91de20ca14725a41ea082b61a98477427c78528.tar.bz2
cuberite-f91de20ca14725a41ea082b61a98477427c78528.tar.lz
cuberite-f91de20ca14725a41ea082b61a98477427c78528.tar.xz
cuberite-f91de20ca14725a41ea082b61a98477427c78528.tar.zst
cuberite-f91de20ca14725a41ea082b61a98477427c78528.zip
Diffstat (limited to 'src/OSSupport/CMakeLists.txt')
-rw-r--r--src/OSSupport/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/OSSupport/CMakeLists.txt b/src/OSSupport/CMakeLists.txt
index e943ceb18..9424b63da 100644
--- a/src/OSSupport/CMakeLists.txt
+++ b/src/OSSupport/CMakeLists.txt
@@ -10,12 +10,17 @@ SET (SRCS
Event.cpp
File.cpp
GZipFile.cpp
+ HostnameLookup.cpp
+ IPLookup.cpp
IsThread.cpp
ListenThread.cpp
+ NetworkSingleton.cpp
Semaphore.cpp
+ ServerHandleImpl.cpp
Socket.cpp
SocketThreads.cpp
StackTrace.cpp
+ TCPLinkImpl.cpp
)
SET (HDRS
@@ -24,13 +29,19 @@ SET (HDRS
Event.h
File.h
GZipFile.h
+ HostnameLookup.h
+ IPLookup.h
IsThread.h
ListenThread.h
+ Network.h
+ NetworkSingleton.h
Queue.h
Semaphore.h
+ ServerHandleImpl.h
Socket.h
SocketThreads.h
StackTrace.h
+ TCPLinkImpl.h
)
if(NOT MSVC)