summaryrefslogtreecommitdiffstats
path: root/src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt
diff options
context:
space:
mode:
authorTiger Wang <ziwei.tiger@outlook.com>2015-12-19 22:20:56 +0100
committerTiger Wang <ziwei.tiger@outlook.com>2015-12-19 22:20:56 +0100
commitb8752bb26e91bcdcebfb8dd43e5794251ff70a89 (patch)
tree95048f5a2a833c1d43785f6eaea070627c2b9ebe /src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt
parentMerge pull request #2776 from cuberite/AtomicBoolIsthread (diff)
parentReorganised the redstone simulator (diff)
downloadcuberite-b8752bb26e91bcdcebfb8dd43e5794251ff70a89.tar
cuberite-b8752bb26e91bcdcebfb8dd43e5794251ff70a89.tar.gz
cuberite-b8752bb26e91bcdcebfb8dd43e5794251ff70a89.tar.bz2
cuberite-b8752bb26e91bcdcebfb8dd43e5794251ff70a89.tar.lz
cuberite-b8752bb26e91bcdcebfb8dd43e5794251ff70a89.tar.xz
cuberite-b8752bb26e91bcdcebfb8dd43e5794251ff70a89.tar.zst
cuberite-b8752bb26e91bcdcebfb8dd43e5794251ff70a89.zip
Diffstat (limited to 'src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt')
-rw-r--r--src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt b/src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt
new file mode 100644
index 000000000..e37f3595c
--- /dev/null
+++ b/src/Simulator/IncrementalRedstoneSimulator/CMakeLists.txt
@@ -0,0 +1,38 @@
+cmake_minimum_required (VERSION 2.6)
+project (MCServer)
+
+include_directories ("${PROJECT_SOURCE_DIR}/../")
+
+set (SRCS
+ IncrementalRedstoneSimulator.cpp
+)
+
+set (HDRS
+ CommandBlockHandler.h
+ DoorHandler.h
+ DropSpenserHandler.h
+ IncrementalRedstoneSimulator.h
+ RedstoneHandler.h
+ RedstoneSimulatorChunkData.h
+ SolidBlockHandler.h
+ RedstoneComparatorHandler.h
+ RedstoneRepeaterHandler.h
+ RedstoneBlockHandler.h
+ RedstoneTorchHandler.h
+ RedstoneWireHandler.h
+ RedstoneLampHandler.h
+ RedstoneToggleHandler.h
+ PistonHandler.h
+ SmallGateHandler.h
+ NoteBlockHandler.h
+ TNTHandler.h
+ TrappedChestHandler.h
+ TripwireHookHandler.h
+ PoweredRailHandler.h
+ PressurePlateHandler.h
+)
+
+if(NOT MSVC)
+ add_library(IncrementalRedstoneSimulator ${SRCS} ${HDRS})
+endif()
+