summaryrefslogtreecommitdiffstats
path: root/lib/lua/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/lua/CMakeLists.txt')
-rw-r--r--lib/lua/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/lua/CMakeLists.txt b/lib/lua/CMakeLists.txt
new file mode 100644
index 000000000..ed1627a67
--- /dev/null
+++ b/lib/lua/CMakeLists.txt
@@ -0,0 +1,17 @@
+
+cmake_minimum_required (VERSION 2.6)
+project (lua)
+
+include_directories ("${PROJECT_SOURCE_DIR}/../../src/")
+
+file(GLOB SOURCE
+ "src/*.c"
+)
+
+if(${STATIC_LUA})
+add_library(lua ${SOURCE})
+else()
+add_library(lua SHARED ${SOURCE})
+endif()
+
+target_link_libraries(lua m)