summaryrefslogtreecommitdiffstats
path: root/tests/BlockTypeRegistry/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/BlockTypeRegistry/CMakeLists.txt')
-rw-r--r--tests/BlockTypeRegistry/CMakeLists.txt42
1 files changed, 21 insertions, 21 deletions
diff --git a/tests/BlockTypeRegistry/CMakeLists.txt b/tests/BlockTypeRegistry/CMakeLists.txt
index ef4803747..b9036ffdf 100644
--- a/tests/BlockTypeRegistry/CMakeLists.txt
+++ b/tests/BlockTypeRegistry/CMakeLists.txt
@@ -1,5 +1,5 @@
find_package(Threads REQUIRED)
-include_directories(${CMAKE_SOURCE_DIR}/src/)
+include_directories(${PROJECT_SOURCE_DIR}/src/)
# Define individual test executables:
@@ -7,21 +7,21 @@ include_directories(${CMAKE_SOURCE_DIR}/src/)
add_executable(BlockStateTest
BlockStateTest.cpp
../TestHelpers.h
- ${CMAKE_SOURCE_DIR}/src/BlockState.cpp
- ${CMAKE_SOURCE_DIR}/src/StringUtils.cpp
- ${CMAKE_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
+ ${PROJECT_SOURCE_DIR}/src/BlockState.cpp
+ ${PROJECT_SOURCE_DIR}/src/StringUtils.cpp
+ ${PROJECT_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
)
target_link_libraries(BlockStateTest fmt::fmt)
add_executable(BlockTypePaletteTest
BlockTypePaletteTest.cpp
../TestHelpers.h
- ${CMAKE_SOURCE_DIR}/src/BlockState.cpp
- ${CMAKE_SOURCE_DIR}/src/BlockTypePalette.cpp
- ${CMAKE_SOURCE_DIR}/src/JsonUtils.cpp
- ${CMAKE_SOURCE_DIR}/src/StringUtils.cpp
- ${CMAKE_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
- ${CMAKE_SOURCE_DIR}/src/OSSupport/File.cpp
+ ${PROJECT_SOURCE_DIR}/src/BlockState.cpp
+ ${PROJECT_SOURCE_DIR}/src/BlockTypePalette.cpp
+ ${PROJECT_SOURCE_DIR}/src/JsonUtils.cpp
+ ${PROJECT_SOURCE_DIR}/src/StringUtils.cpp
+ ${PROJECT_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
+ ${PROJECT_SOURCE_DIR}/src/OSSupport/File.cpp
)
target_link_libraries(BlockTypePaletteTest fmt::fmt jsoncpp_lib)
@@ -29,9 +29,9 @@ target_link_libraries(BlockTypePaletteTest fmt::fmt jsoncpp_lib)
add_executable(BlockTypeRegistryTest
BlockTypeRegistryTest.cpp
../TestHelpers.h
- ${CMAKE_SOURCE_DIR}/src/BlockTypeRegistry.cpp
- ${CMAKE_SOURCE_DIR}/src/StringUtils.cpp
- ${CMAKE_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
+ ${PROJECT_SOURCE_DIR}/src/BlockTypeRegistry.cpp
+ ${PROJECT_SOURCE_DIR}/src/StringUtils.cpp
+ ${PROJECT_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
)
target_link_libraries(BlockTypeRegistryTest fmt::fmt Threads::Threads)
@@ -39,14 +39,14 @@ target_link_libraries(BlockTypeRegistryTest fmt::fmt Threads::Threads)
add_executable(PalettedBlockAreaTest
PalettedBlockAreaTest.cpp
../TestHelpers.h
- ${CMAKE_SOURCE_DIR}/src/BlockState.cpp
- ${CMAKE_SOURCE_DIR}/src/BlockTypeRegistry.cpp
- ${CMAKE_SOURCE_DIR}/src/BlockTypePalette.cpp
- ${CMAKE_SOURCE_DIR}/src/Cuboid.cpp
- ${CMAKE_SOURCE_DIR}/src/JsonUtils.cpp
- ${CMAKE_SOURCE_DIR}/src/PalettedBlockArea.cpp
- ${CMAKE_SOURCE_DIR}/src/StringUtils.cpp
- ${CMAKE_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
+ ${PROJECT_SOURCE_DIR}/src/BlockState.cpp
+ ${PROJECT_SOURCE_DIR}/src/BlockTypeRegistry.cpp
+ ${PROJECT_SOURCE_DIR}/src/BlockTypePalette.cpp
+ ${PROJECT_SOURCE_DIR}/src/Cuboid.cpp
+ ${PROJECT_SOURCE_DIR}/src/JsonUtils.cpp
+ ${PROJECT_SOURCE_DIR}/src/PalettedBlockArea.cpp
+ ${PROJECT_SOURCE_DIR}/src/StringUtils.cpp
+ ${PROJECT_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
)
target_link_libraries(PalettedBlockAreaTest fmt::fmt jsoncpp_lib)