summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorH Lohaus <hlohaus@users.noreply.github.com>2024-03-28 17:17:59 +0100
committerGitHub <noreply@github.com>2024-03-28 17:17:59 +0100
commit64e07b7fbf810176d66506786a946a3122ea7fc4 (patch)
tree1cf10ab4f117583fdb4a98712c18052e5a42cdf2 /setup.py
parentMerge pull request #1758 from Zero6992/main (diff)
parentFix history support for OpenaiChat (diff)
downloadgpt4free-64e07b7fbf810176d66506786a946a3122ea7fc4.tar
gpt4free-64e07b7fbf810176d66506786a946a3122ea7fc4.tar.gz
gpt4free-64e07b7fbf810176d66506786a946a3122ea7fc4.tar.bz2
gpt4free-64e07b7fbf810176d66506786a946a3122ea7fc4.tar.lz
gpt4free-64e07b7fbf810176d66506786a946a3122ea7fc4.tar.xz
gpt4free-64e07b7fbf810176d66506786a946a3122ea7fc4.tar.zst
gpt4free-64e07b7fbf810176d66506786a946a3122ea7fc4.zip
Diffstat (limited to '')
-rw-r--r--setup.py24
1 files changed, 16 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 58fa5ae9..9b3f12d0 100644
--- a/setup.py
+++ b/setup.py
@@ -20,22 +20,27 @@ EXTRA_REQUIRE = {
"curl_cffi>=0.6.2",
"certifi",
"browser_cookie3", # get_cookies
- "PyExecJS", # GptForLove
+ "PyExecJS", # GptForLove, Vercel
"duckduckgo-search>=5.0" ,# internet.search
"beautifulsoup4", # internet.search and bing.create_images
- "brotli", # openai
- #"undetected-chromedriver>=3.5.5", # webdriver
- #"setuptools", # webdriver
+ "brotli", # openai, bing
+ # webdriver
+ #"undetected-chromedriver>=3.5.5",
+ #"setuptools",
+ #"selenium-wire"
+ # webview
"pywebview",
"platformdirs",
"plyer",
+ "cryptography",
+ ####
"aiohttp_socks", # proxy
"pillow", # image
"cairosvg", # svg image
"werkzeug", "flask", # gui
- "loguru", "fastapi",
+ "loguru", "fastapi", # api
"uvicorn", "nest_asyncio", # api
- #"selenium-wire"
+ "pycryptodome" # openai
],
"image": [
"pillow",
@@ -51,9 +56,12 @@ EXTRA_REQUIRE = {
"webview": [
"webview",
"platformdirs",
- "plyer"
+ "plyer",
+ "cryptography"
+ ],
+ "openai": [
+ "pycryptodome"
],
- "openai": [],
"api": [
"loguru", "fastapi",
"uvicorn", "nest_asyncio"