summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorTekky <98614666+xtekky@users.noreply.github.com>2023-09-05 16:04:00 +0200
committerGitHub <noreply@github.com>2023-09-05 16:04:00 +0200
commit8fe76cc4c9f6896576a07fde883638c6494a2ea1 (patch)
tree7bb838d27a87a2d92d6ed92e00d0ad150a8ffbc6 /setup.py
parent~ | Merge pull request #876 from Lin-jun-xiang/join_messages (diff)
parentMerge branch 'main' into add-console-script (diff)
downloadgpt4free-8fe76cc4c9f6896576a07fde883638c6494a2ea1.tar
gpt4free-8fe76cc4c9f6896576a07fde883638c6494a2ea1.tar.gz
gpt4free-8fe76cc4c9f6896576a07fde883638c6494a2ea1.tar.bz2
gpt4free-8fe76cc4c9f6896576a07fde883638c6494a2ea1.tar.lz
gpt4free-8fe76cc4c9f6896576a07fde883638c6494a2ea1.tar.xz
gpt4free-8fe76cc4c9f6896576a07fde883638c6494a2ea1.tar.zst
gpt4free-8fe76cc4c9f6896576a07fde883638c6494a2ea1.zip
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 13 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index ef4e3d61..698c6f6d 100644
--- a/setup.py
+++ b/setup.py
@@ -11,7 +11,10 @@ with codecs.open(os.path.join(here, "README.md"), encoding="utf-8") as fh:
with open("requirements.txt") as f:
required = f.read().splitlines()
-VERSION = '0.0.2.6'
+with open("interference/requirements.txt") as f:
+ api_required = f.read().splitlines()
+
+VERSION = "0.0.2.6"
DESCRIPTION = (
"The official gpt4free repository | various collection of powerful language models"
)
@@ -26,11 +29,16 @@ setup(
long_description_content_type="text/markdown",
long_description=long_description,
packages=find_packages(),
+ data_files=["interference/app.py"],
install_requires=required,
- url='https://github.com/xtekky/gpt4free', # Link to your GitHub repository
+ extras_require={"api": api_required},
+ entry_points={
+ "console_scripts": ["g4f=interference.app:main"],
+ },
+ url="https://github.com/xtekky/gpt4free", # Link to your GitHub repository
project_urls={
- 'Source Code': 'https://github.com/xtekky/gpt4free', # GitHub link
- 'Bug Tracker': 'https://github.com/xtekky/gpt4free/issues', # Link to issue tracker
+ "Source Code": "https://github.com/xtekky/gpt4free", # GitHub link
+ "Bug Tracker": "https://github.com/xtekky/gpt4free/issues", # Link to issue tracker
},
keywords=[
"python",
@@ -65,4 +73,4 @@ setup(
"Operating System :: MacOS :: MacOS X",
"Operating System :: Microsoft :: Windows",
],
-) \ No newline at end of file
+)