summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRyan Jordan <ryjordan@gmail.com>2023-09-06 02:39:57 +0200
committerGitHub <noreply@github.com>2023-09-06 02:39:57 +0200
commitf81e618958318a092ca4c70a1b3ea15260bda97c (patch)
tree3ce022a8d719011268da7f1a0befc97bf32a60d8 /setup.py
parentfeat(docker): add Docker and Docker Compose support (diff)
parent~ | Merge pull request #869 from ahobsonsayers/add-console-script (diff)
downloadgpt4free-f81e618958318a092ca4c70a1b3ea15260bda97c.tar
gpt4free-f81e618958318a092ca4c70a1b3ea15260bda97c.tar.gz
gpt4free-f81e618958318a092ca4c70a1b3ea15260bda97c.tar.bz2
gpt4free-f81e618958318a092ca4c70a1b3ea15260bda97c.tar.lz
gpt4free-f81e618958318a092ca4c70a1b3ea15260bda97c.tar.xz
gpt4free-f81e618958318a092ca4c70a1b3ea15260bda97c.tar.zst
gpt4free-f81e618958318a092ca4c70a1b3ea15260bda97c.zip
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 12 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 10743750..698c6f6d 100644
--- a/setup.py
+++ b/setup.py
@@ -11,7 +11,10 @@ with codecs.open(os.path.join(here, "README.md"), encoding="utf-8") as fh:
with open("requirements.txt") as f:
required = f.read().splitlines()
-VERSION = '0.0.2.3'
+with open("interference/requirements.txt") as f:
+ api_required = f.read().splitlines()
+
+VERSION = "0.0.2.6"
DESCRIPTION = (
"The official gpt4free repository | various collection of powerful language models"
)
@@ -26,11 +29,16 @@ setup(
long_description_content_type="text/markdown",
long_description=long_description,
packages=find_packages(),
+ data_files=["interference/app.py"],
install_requires=required,
- url='https://github.com/xtekky/gpt4free', # Link to your GitHub repository
+ extras_require={"api": api_required},
+ entry_points={
+ "console_scripts": ["g4f=interference.app:main"],
+ },
+ url="https://github.com/xtekky/gpt4free", # Link to your GitHub repository
project_urls={
- 'Source Code': 'https://github.com/xtekky/gpt4free', # GitHub link
- 'Bug Tracker': 'https://github.com/xtekky/gpt4free/issues', # Link to issue tracker
+ "Source Code": "https://github.com/xtekky/gpt4free", # GitHub link
+ "Bug Tracker": "https://github.com/xtekky/gpt4free/issues", # Link to issue tracker
},
keywords=[
"python",