summaryrefslogtreecommitdiffstats
path: root/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info
diff options
context:
space:
mode:
authornoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
committernoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
commit355dee533bb34a571b9367820a63cccb668cf866 (patch)
tree838af886b4fec07320aeb10f0d1e74ba79e79b5c /venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info
parentadded pyproject.toml file (diff)
downloadgpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.gz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.bz2
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.lz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.xz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.zst
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.zip
Diffstat (limited to 'venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info')
-rw-r--r--venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/INSTALLER1
-rw-r--r--venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/LICENSE21
-rw-r--r--venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/METADATA187
-rw-r--r--venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/RECORD23
-rw-r--r--venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/REQUESTED0
-rw-r--r--venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/WHEEL5
-rw-r--r--venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/top_level.txt1
7 files changed, 238 insertions, 0 deletions
diff --git a/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/INSTALLER b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/INSTALLER
new file mode 100644
index 00000000..a1b589e3
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/INSTALLER
@@ -0,0 +1 @@
+pip
diff --git a/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/LICENSE b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/LICENSE
new file mode 100644
index 00000000..3ea0507d
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2021 xHossein
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/METADATA b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/METADATA
new file mode 100644
index 00000000..42d49fa4
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/METADATA
@@ -0,0 +1,187 @@
+Metadata-Version: 2.1
+Name: PyPasser
+Version: 0.0.5
+Summary: Bypassing reCaptcha V3 by sending HTTP requests & solving reCaptcha V2 using speech to text.
+Home-page: https://github.com/xHossein/PyPasser
+Author: xHossein
+License: MIT
+Keywords: Bypass reCaptcha V3,Bypass-reCaptcha-V3,Bypass reCaptcha,Bypass-reCaptcha,Bypass reCaptcha V2,Bypass-reCaptcha-V2,Solve-reCaptcha-V2,Google reCaptcha,Google-reCaptcha
+Classifier: Development Status :: 4 - Beta
+Classifier: Intended Audience :: Developers
+Classifier: License :: OSI Approved :: MIT License
+Classifier: Topic :: Software Development :: Libraries :: Python Modules
+Classifier: Programming Language :: Python :: 3.7
+Classifier: Programming Language :: Python :: 3.8
+Requires-Python: >=3.7
+Description-Content-Type: text/markdown
+License-File: LICENSE
+Requires-Dist: requests (<3.0,>=2.25.1)
+Requires-Dist: PySocks (==1.7.1)
+Requires-Dist: SpeechRecognition (==3.8.1)
+Requires-Dist: pydub (==0.25.1)
+Requires-Dist: selenium
+
+# PyPasser
+
+**PyPasser** is a Python library for bypassing reCaptchaV3 only by sending HTTP requests and solving reCaptchaV2 using speech-to-text engine.
+
+🔴 reCaptchaV3 bypass does not work on all sites. Test on your target to find out.
+
+🐍 Support Python >= 3.7
+
+# Installation
+
+### Install from PyPI
+
+```
+pip install PyPasser
+```
+
+### And for update
+
+```
+pip install PyPasser --upgrade
+```
+
+&nbsp;
+
+### Install from Github (latest repo code)
+
+```
+pip install git+https://github.com/xHossein/PyPasser@master
+```
+
+&nbsp;
+
+
+# Bypassing **reCaptchaV3**
+
+To bypass recaptcha v3, first you must find anchor URL.
+
+- Open inspect-element on your browser.
+- Go to the web page that has reCaptcha V3 (not V2 invisible).
+- In Network tab you should see many requests.
+- Type `anchor` in text-field filter to hide unnecessary requests.
+- Now you should see a url like this:
+
+ > ``https://www.google.com/recaptcha/api2/anchor?ar=1&k=6LfCVLAUAAAAFwwRnnCFW_J39&co=aHR....``
+ >
+
+ pass this url to `reCaptchaV3` class:
+
+Note that the anchor urls also can have `/enterprise/anchor` instead of `/api2/anchor` in other sites.
+
+&nbsp;
+
+```python
+from pypasser import reCaptchaV3
+
+reCaptcha_response = reCaptchaV3('ANCHOR URL')
+## use this response in your request ...
+```
+
+Some good examples are [here](https://github.com/xHossein/PyPasser/tree/master/examples/reCaptchaV3).
+
+&nbsp;
+
+### **Proxy**
+
+```python
+from pypasser import reCaptchaV3
+from pypasser.structs import Proxy
+
+## Using Proxy structure
+proxy = Proxy(Proxy.type.HTTPs,'HOST','PORT')
+
+## with authentication credentials
+# proxy = Proxy(Proxy.type.HTTPs,'HOST','PORT','USERNAME', 'PASSWORD')
+
+reCaptcha_response = reCaptchaV3('ANCHOR URL', proxy)
+```
+
+_also you can configure it as Dict._
+
+```python
+
+proxy = {"http": "http://HOST:PORT",
+ "https": "https://HOST:PORT"}
+
+reCaptcha_response = reCaptchaV3('ANCHOR URL', proxy)
+```
+
+&nbsp;
+
+### **Timeout**
+
+Default timeout is `20 seconds` but you can change the amount like this:
+
+```python
+from pypasser import reCaptchaV3
+
+reCaptcha_response = reCaptchaV3('ANCHOR URL', timeout = 10)
+```
+
+&nbsp;
+
+# Bypassing **reCaptchaV2**
+Before start using reCaptchaV2 solver, you must install the following requirements.
+### **Requirements** :
+- **PocketSphinx** (used as speech-to-text engine)
+- **ffmpeg** (used for audio format conversion)
+
+After installing requirements, you should pass your webdriver to reCaptchaV2 class then PyPasser tries to solve the reCaptcha V2 which is in current tab of browser.
+```python
+from pypasser import reCaptchaV2
+
+# Create an instance of webdriver and open the page has recaptcha v2
+# ...
+
+# pass the driver to reCaptchaV2
+is_checked = reCaptchaV2(driver_instance) # it returns bool
+
+```
+
+&nbsp;
+
+### **Arguments**
+**driver**: An instance of webdriver.\
+**Play**: Click on 'PLAY' button. [Default is True means it plays the audio].\
+**Attempts**: Maximum solving attempts for a recaptcha. [Default is 3 times].
+
+```python
+is_checked = reCaptchaV2(
+ driver = driver_instance,
+ play = False,
+ attempts = 5
+ )
+
+```
+
+
+See an example [here](https://github.com/xHossein/PyPasser/blob/master/examples/reCaptchaV2/demo.py).
+
+> Note that Google gonna blocks you if you try to solve many recaptcha via audio challenge. In this case PyPasser raises `IpBlock` exception.
+
+&nbsp;
+
+# Exception
+
+| Exception | Bypass | Description |
+| ---------- | -------------- | --------------- |
+| ConnectionError | reCaptchaV3 | Raised due to network connectivity-related issues. |
+| RecaptchaTokenNotFound | reCaptchaV3 | Raised when couldn't find token due to wrong `anchor_url`. |
+| RecaptchaResponseNotFound | reCaptchaV3 | Raised when couldn't find reCaptcha response due to using **PyPasser** for site that hasn't reCaptchaV3. |
+| IpBlock | reCaptchaV2 | Raised due to solving many recaptcha via audio challenge. |
+
+&nbsp;
+
+# Legal Disclaimer
+
+This was made for educational purposes only, nobody which directly involved in this project is responsible for any damages caused.
+**You are responsible for your actions.**
+
+&nbsp;
+
+# License
+
+[MIT](https://choosealicense.com/licenses/mit/)
diff --git a/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/RECORD b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/RECORD
new file mode 100644
index 00000000..1a0f4f7f
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/RECORD
@@ -0,0 +1,23 @@
+PyPasser-0.0.5.dist-info/INSTALLER,sha256=zuuue4knoyJ-UwPPXg8fezS7VCrXJQrAP7zeNuwvFQg,4
+PyPasser-0.0.5.dist-info/LICENSE,sha256=aWmbOb2ZPRr0vRoPtoXatGEwHEn9vqXatlWmdx1P9_w,1086
+PyPasser-0.0.5.dist-info/METADATA,sha256=A1kF49zOn1swXpMA5M-7cWrqZhv3YQX_Iupec40MYEI,5153
+PyPasser-0.0.5.dist-info/RECORD,,
+PyPasser-0.0.5.dist-info/REQUESTED,sha256=47DEQpj8HBSa-_TImW-5JCeuQeRkm5NMpJWZG3hSuFU,0
+PyPasser-0.0.5.dist-info/WHEEL,sha256=pkctZYzUS4AYVn6dJ-7367OJZivF2e8RA9b_ZBjif18,92
+PyPasser-0.0.5.dist-info/top_level.txt,sha256=UZdUAeOE4wZr2Eyr8ZaXMIrHVuXHwWL9_bA9BnADNGc,9
+pypasser/__init__.py,sha256=HuGbxzhC2BBzcW6yPhLKjQ893up9d8hR7WBgestPn7Q,74
+pypasser/__pycache__/__init__.cpython-39.pyc,,
+pypasser/__pycache__/exceptions.cpython-39.pyc,,
+pypasser/__pycache__/session.cpython-39.pyc,,
+pypasser/__pycache__/structs.cpython-39.pyc,,
+pypasser/__pycache__/utils.cpython-39.pyc,,
+pypasser/exceptions.py,sha256=0Hoky7gXUe9AoUcmAd8CTUXdSvX_I83IQVca-1SzKzs,483
+pypasser/reCaptchaV2/__init__.py,sha256=VZwdjs8z3427WK7gifRZe6vTfowxuWmd-WlIFCOHJDk,4555
+pypasser/reCaptchaV2/__pycache__/__init__.cpython-39.pyc,,
+pypasser/reCaptchaV3/__init__.py,sha256=IresS_gduwUeSRn6kjxKEKXikTWNSBTgOIfVo9-2SH0,3149
+pypasser/reCaptchaV3/__pycache__/__init__.cpython-39.pyc,,
+pypasser/reCaptchaV3/__pycache__/constants.cpython-39.pyc,,
+pypasser/reCaptchaV3/constants.py,sha256=UMU58EjmaGVQnf3N32jb7rqwct8dLFLSQc6jLhNJAPI,3354
+pypasser/session.py,sha256=TXkI5pMlkSYtT0N3L5VmNqo5vyqfjRM6GoeT3mLb_I4,1405
+pypasser/structs.py,sha256=xvZ96bTC-BScH5xq8iyG8OJRI2hQ5cwgwN_jQYiyvzo,559
+pypasser/utils.py,sha256=isVJQn2VHwcnuEqnUHOZVNbMXCwAYo-xiPIXwIS0CV8,1603
diff --git a/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/REQUESTED b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/REQUESTED
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/REQUESTED
diff --git a/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/WHEEL b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/WHEEL
new file mode 100644
index 00000000..1f37c02f
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/WHEEL
@@ -0,0 +1,5 @@
+Wheel-Version: 1.0
+Generator: bdist_wheel (0.40.0)
+Root-Is-Purelib: true
+Tag: py3-none-any
+
diff --git a/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/top_level.txt b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/top_level.txt
new file mode 100644
index 00000000..26b35c6d
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/PyPasser-0.0.5.dist-info/top_level.txt
@@ -0,0 +1 @@
+pypasser