summaryrefslogtreecommitdiffstats
path: root/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info
diff options
context:
space:
mode:
authornoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
committernoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
commit355dee533bb34a571b9367820a63cccb668cf866 (patch)
tree838af886b4fec07320aeb10f0d1e74ba79e79b5c /venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info
parentadded pyproject.toml file (diff)
downloadgpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.gz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.bz2
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.lz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.xz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.zst
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.zip
Diffstat (limited to 'venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info')
-rw-r--r--venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/INSTALLER1
-rw-r--r--venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/LICENSE.rst20
-rw-r--r--venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/METADATA63
-rw-r--r--venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/RECORD15
-rw-r--r--venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/WHEEL5
-rw-r--r--venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/top_level.txt1
6 files changed, 105 insertions, 0 deletions
diff --git a/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/INSTALLER b/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/INSTALLER
new file mode 100644
index 00000000..a1b589e3
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/INSTALLER
@@ -0,0 +1 @@
+pip
diff --git a/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/LICENSE.rst b/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/LICENSE.rst
new file mode 100644
index 00000000..79c9825a
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/LICENSE.rst
@@ -0,0 +1,20 @@
+Copyright 2010 Jason Kirtland
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/METADATA b/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/METADATA
new file mode 100644
index 00000000..d181f19f
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/METADATA
@@ -0,0 +1,63 @@
+Metadata-Version: 2.1
+Name: blinker
+Version: 1.6.2
+Summary: Fast, simple object-to-object and broadcast signaling
+Author-email: Jason Kirtland <jek@discorporate.us>
+Maintainer-email: Pallets Ecosystem <contact@palletsprojects.com>
+License: MIT License
+Project-URL: Homepage, https://blinker.readthedocs.io
+Project-URL: Documentation, https://blinker.readthedocs.io
+Project-URL: Source Code, https://github.com/pallets-eco/blinker/
+Project-URL: Issue Tracker, https://github.com/pallets-eco/blinker/issues/
+Project-URL: Chat, https://discord.gg/pallets
+Keywords: signal,emit,events,broadcast
+Classifier: Development Status :: 5 - Production/Stable
+Classifier: Intended Audience :: Developers
+Classifier: License :: OSI Approved :: MIT License
+Classifier: Operating System :: OS Independent
+Classifier: Programming Language :: Python
+Classifier: Topic :: Software Development :: Libraries
+Requires-Python: >=3.7
+Description-Content-Type: text/x-rst
+License-File: LICENSE.rst
+
+Blinker
+=======
+
+Blinker provides a fast dispatching system that allows any number of
+interested parties to subscribe to events, or "signals".
+
+Signal receivers can subscribe to specific senders or receive signals
+sent by any sender.
+
+.. code-block:: pycon
+
+ >>> from blinker import signal
+ >>> started = signal('round-started')
+ >>> def each(round):
+ ... print(f"Round {round}")
+ ...
+ >>> started.connect(each)
+
+ >>> def round_two(round):
+ ... print("This is round two.")
+ ...
+ >>> started.connect(round_two, sender=2)
+
+ >>> for round in range(1, 4):
+ ... started.send(round)
+ ...
+ Round 1!
+ Round 2!
+ This is round two.
+ Round 3!
+
+
+Links
+-----
+
+- Documentation: https://blinker.readthedocs.io/
+- Changes: https://blinker.readthedocs.io/#changes
+- PyPI Releases: https://pypi.org/project/blinker/
+- Source Code: https://github.com/pallets-eco/blinker/
+- Issue Tracker: https://github.com/pallets-eco/blinker/issues/
diff --git a/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/RECORD b/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/RECORD
new file mode 100644
index 00000000..70bcdcb2
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/RECORD
@@ -0,0 +1,15 @@
+blinker-1.6.2.dist-info/INSTALLER,sha256=zuuue4knoyJ-UwPPXg8fezS7VCrXJQrAP7zeNuwvFQg,4
+blinker-1.6.2.dist-info/LICENSE.rst,sha256=nrc6HzhZekqhcCXSrhvjg5Ykx5XphdTw6Xac4p-spGc,1054
+blinker-1.6.2.dist-info/METADATA,sha256=7MRskabu2wQvWIMFwgqP3w2LDt8nR5nCxH7Anu1ZrBM,1964
+blinker-1.6.2.dist-info/RECORD,,
+blinker-1.6.2.dist-info/WHEEL,sha256=pkctZYzUS4AYVn6dJ-7367OJZivF2e8RA9b_ZBjif18,92
+blinker-1.6.2.dist-info/top_level.txt,sha256=2NmsENM0J2t9Z8mkjxHDmGMQj7Bm8f5ZTTYe1x1fZtM,8
+blinker/__init__.py,sha256=Ko7EbvxyCl_UewgsP8XgDJqJcHZA7EsuhG72R_zDrcY,408
+blinker/__pycache__/__init__.cpython-39.pyc,,
+blinker/__pycache__/_saferef.cpython-39.pyc,,
+blinker/__pycache__/_utilities.cpython-39.pyc,,
+blinker/__pycache__/base.cpython-39.pyc,,
+blinker/_saferef.py,sha256=kWOTIWnCY3kOb8lZP74Rbx7bR_BLVg4TjwzNCRLhKHs,9096
+blinker/_utilities.py,sha256=GPXtJzykzVotoxHC79mgFQMPJtICwpVDCCpus4_JtsA,4110
+blinker/base.py,sha256=7Y-C0ZVIe-NrrskPeqj0bLSp4R6Cpq5LrzI1DmLqMEA,20469
+blinker/py.typed,sha256=47DEQpj8HBSa-_TImW-5JCeuQeRkm5NMpJWZG3hSuFU,0
diff --git a/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/WHEEL b/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/WHEEL
new file mode 100644
index 00000000..1f37c02f
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/WHEEL
@@ -0,0 +1,5 @@
+Wheel-Version: 1.0
+Generator: bdist_wheel (0.40.0)
+Root-Is-Purelib: true
+Tag: py3-none-any
+
diff --git a/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/top_level.txt b/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/top_level.txt
new file mode 100644
index 00000000..1ff4ca55
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/blinker-1.6.2.dist-info/top_level.txt
@@ -0,0 +1 @@
+blinker