summaryrefslogtreecommitdiffstats
path: root/venv/lib/python3.9/site-packages/pyarrow/config.pxi
diff options
context:
space:
mode:
authornoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
committernoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
commit355dee533bb34a571b9367820a63cccb668cf866 (patch)
tree838af886b4fec07320aeb10f0d1e74ba79e79b5c /venv/lib/python3.9/site-packages/pyarrow/config.pxi
parentadded pyproject.toml file (diff)
downloadgpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.gz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.bz2
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.lz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.xz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.zst
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.zip
Diffstat (limited to 'venv/lib/python3.9/site-packages/pyarrow/config.pxi')
-rw-r--r--venv/lib/python3.9/site-packages/pyarrow/config.pxi76
1 files changed, 76 insertions, 0 deletions
diff --git a/venv/lib/python3.9/site-packages/pyarrow/config.pxi b/venv/lib/python3.9/site-packages/pyarrow/config.pxi
new file mode 100644
index 00000000..fb9526ba
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/pyarrow/config.pxi
@@ -0,0 +1,76 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+from pyarrow.includes.libarrow cimport GetBuildInfo
+
+from collections import namedtuple
+
+
+VersionInfo = namedtuple('VersionInfo', ('major', 'minor', 'patch'))
+
+BuildInfo = namedtuple(
+ 'BuildInfo',
+ ('version', 'version_info', 'so_version', 'full_so_version',
+ 'compiler_id', 'compiler_version', 'compiler_flags',
+ 'git_id', 'git_description', 'package_kind', 'build_type'))
+
+RuntimeInfo = namedtuple('RuntimeInfo',
+ ('simd_level', 'detected_simd_level'))
+
+cdef _build_info():
+ cdef:
+ const CBuildInfo* c_info
+
+ c_info = &GetBuildInfo()
+
+ return BuildInfo(version=frombytes(c_info.version_string),
+ version_info=VersionInfo(c_info.version_major,
+ c_info.version_minor,
+ c_info.version_patch),
+ so_version=frombytes(c_info.so_version),
+ full_so_version=frombytes(c_info.full_so_version),
+ compiler_id=frombytes(c_info.compiler_id),
+ compiler_version=frombytes(c_info.compiler_version),
+ compiler_flags=frombytes(c_info.compiler_flags),
+ git_id=frombytes(c_info.git_id),
+ git_description=frombytes(c_info.git_description),
+ package_kind=frombytes(c_info.package_kind),
+ build_type=frombytes(c_info.build_type).lower(),
+ )
+
+
+cpp_build_info = _build_info()
+cpp_version = cpp_build_info.version
+cpp_version_info = cpp_build_info.version_info
+
+
+def runtime_info():
+ """
+ Get runtime information.
+
+ Returns
+ -------
+ info : pyarrow.RuntimeInfo
+ """
+ cdef:
+ CRuntimeInfo c_info
+
+ c_info = GetRuntimeInfo()
+
+ return RuntimeInfo(
+ simd_level=frombytes(c_info.simd_level),
+ detected_simd_level=frombytes(c_info.detected_simd_level))