summaryrefslogtreecommitdiffstats
path: root/venv/lib/python3.9/site-packages/pyarrow/flight.py
diff options
context:
space:
mode:
authornoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
committernoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
commit355dee533bb34a571b9367820a63cccb668cf866 (patch)
tree838af886b4fec07320aeb10f0d1e74ba79e79b5c /venv/lib/python3.9/site-packages/pyarrow/flight.py
parentadded pyproject.toml file (diff)
downloadgpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.gz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.bz2
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.lz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.xz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.zst
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.zip
Diffstat (limited to 'venv/lib/python3.9/site-packages/pyarrow/flight.py')
-rw-r--r--venv/lib/python3.9/site-packages/pyarrow/flight.py64
1 files changed, 64 insertions, 0 deletions
diff --git a/venv/lib/python3.9/site-packages/pyarrow/flight.py b/venv/lib/python3.9/site-packages/pyarrow/flight.py
new file mode 100644
index 00000000..8f9fa6fa
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/pyarrow/flight.py
@@ -0,0 +1,64 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+from pyarrow._flight import ( # noqa:F401
+ connect,
+ Action,
+ ActionType,
+ BasicAuth,
+ CallInfo,
+ CertKeyPair,
+ ClientAuthHandler,
+ ClientMiddleware,
+ ClientMiddlewareFactory,
+ DescriptorType,
+ FlightCallOptions,
+ FlightCancelledError,
+ FlightClient,
+ FlightDataStream,
+ FlightDescriptor,
+ FlightEndpoint,
+ FlightError,
+ FlightInfo,
+ FlightInternalError,
+ FlightMetadataReader,
+ FlightMetadataWriter,
+ FlightMethod,
+ FlightServerBase,
+ FlightServerError,
+ FlightStreamChunk,
+ FlightStreamReader,
+ FlightStreamWriter,
+ FlightTimedOutError,
+ FlightUnauthenticatedError,
+ FlightUnauthorizedError,
+ FlightUnavailableError,
+ FlightWriteSizeExceededError,
+ GeneratorStream,
+ Location,
+ MetadataRecordBatchReader,
+ MetadataRecordBatchWriter,
+ RecordBatchStream,
+ Result,
+ SchemaResult,
+ ServerAuthHandler,
+ ServerCallContext,
+ ServerMiddleware,
+ ServerMiddlewareFactory,
+ Ticket,
+ TracingServerMiddlewareFactory,
+)