summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2020-08-03 17:03:30 +0200
committerLioncash <mathew1800@gmail.com>2020-08-03 17:21:24 +0200
commitdd2ff236217cb02275cbfa66f50c265a578d1f1e (patch)
tree39f2fbf829fa9fd949103862a75ff3594ca3a6b3 /src/CMakeLists.txt
parentipc: Allow all trivially copyable objects to be passed directly into WriteBuffer (#4465) (diff)
downloadyuzu-dd2ff236217cb02275cbfa66f50c265a578d1f1e.tar
yuzu-dd2ff236217cb02275cbfa66f50c265a578d1f1e.tar.gz
yuzu-dd2ff236217cb02275cbfa66f50c265a578d1f1e.tar.bz2
yuzu-dd2ff236217cb02275cbfa66f50c265a578d1f1e.tar.lz
yuzu-dd2ff236217cb02275cbfa66f50c265a578d1f1e.tar.xz
yuzu-dd2ff236217cb02275cbfa66f50c265a578d1f1e.tar.zst
yuzu-dd2ff236217cb02275cbfa66f50c265a578d1f1e.zip
Diffstat (limited to '')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 54dca3302..71efbb40d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -60,9 +60,14 @@ else()
-Wmissing-declarations
-Wno-attributes
-Wno-unused-parameter
- -fconcepts
)
+ # TODO: Remove when we update to a GCC compiler that enables this
+ # by default (i.e. GCC 10 or newer).
+ if (CMAKE_CXX_COMPILER_ID STREQUAL GNU)
+ add_compile_options(-fconcepts)
+ endif()
+
if (ARCHITECTURE_x86_64)
add_compile_options("-mcx16")
endif()