summaryrefslogtreecommitdiffstats
path: root/src/citra/CMakeLists.txt
diff options
context:
space:
mode:
authorJohannes Ekberg <uppfinnarn@gmail.com>2014-12-24 10:34:25 +0100
committerJohannes Ekberg <uppfinnarn@gmail.com>2015-01-09 15:50:46 +0100
commit7d7ab70279df554959eec29ff43a2eb304a3d578 (patch)
tree13443156725388ffc3fe8b1208a7a39c6d29ea93 /src/citra/CMakeLists.txt
parentMerge pull request #255 from Subv/cbranch_3 (diff)
downloadyuzu-7d7ab70279df554959eec29ff43a2eb304a3d578.tar
yuzu-7d7ab70279df554959eec29ff43a2eb304a3d578.tar.gz
yuzu-7d7ab70279df554959eec29ff43a2eb304a3d578.tar.bz2
yuzu-7d7ab70279df554959eec29ff43a2eb304a3d578.tar.lz
yuzu-7d7ab70279df554959eec29ff43a2eb304a3d578.tar.xz
yuzu-7d7ab70279df554959eec29ff43a2eb304a3d578.tar.zst
yuzu-7d7ab70279df554959eec29ff43a2eb304a3d578.zip
Diffstat (limited to '')
-rw-r--r--src/citra/CMakeLists.txt12
1 files changed, 1 insertions, 11 deletions
diff --git a/src/citra/CMakeLists.txt b/src/citra/CMakeLists.txt
index bbb3374f2..7f3ab3e07 100644
--- a/src/citra/CMakeLists.txt
+++ b/src/citra/CMakeLists.txt
@@ -16,20 +16,10 @@ create_directory_groups(${SRCS} ${HEADERS})
add_executable(citra ${SRCS} ${HEADERS})
target_link_libraries(citra core common video_core)
target_link_libraries(citra ${GLFW_LIBRARIES} ${OPENGL_gl_LIBRARY} inih)
+target_link_libraries(citra ${PLATFORM_LIBRARIES})
if (UNIX)
target_link_libraries(citra -pthread)
endif()
-if (APPLE)
- target_link_libraries(citra iconv ${COREFOUNDATION_LIBRARY})
-elseif (WIN32)
- target_link_libraries(citra winmm wsock32 ws2_32)
- if (MINGW) # GCC does not support codecvt, so use iconv instead
- target_link_libraries(citra iconv)
- endif()
-else() # Unix
- target_link_libraries(citra rt)
-endif()
-
#install(TARGETS citra RUNTIME DESTINATION ${bindir})