summaryrefslogtreecommitdiffstats
path: root/src/citra_qt/CMakeLists.txt
diff options
context:
space:
mode:
authorSacha <xsacha@gmail.com>2014-08-19 13:34:00 +0200
committerSacha <xsacha@gmail.com>2014-08-19 13:34:00 +0200
commit90f23020f53c94dab800f7348877aae483974512 (patch)
treedffeef80b636b9f8baee1f70820dc9536f7d8567 /src/citra_qt/CMakeLists.txt
parentMerge pull request #55 from lioncash/string (diff)
downloadyuzu-90f23020f53c94dab800f7348877aae483974512.tar
yuzu-90f23020f53c94dab800f7348877aae483974512.tar.gz
yuzu-90f23020f53c94dab800f7348877aae483974512.tar.bz2
yuzu-90f23020f53c94dab800f7348877aae483974512.tar.lz
yuzu-90f23020f53c94dab800f7348877aae483974512.tar.xz
yuzu-90f23020f53c94dab800f7348877aae483974512.tar.zst
yuzu-90f23020f53c94dab800f7348877aae483974512.zip
Diffstat (limited to '')
-rw-r--r--src/citra_qt/CMakeLists.txt32
1 files changed, 19 insertions, 13 deletions
diff --git a/src/citra_qt/CMakeLists.txt b/src/citra_qt/CMakeLists.txt
index 5ce4e3f16..ff1fbc460 100644
--- a/src/citra_qt/CMakeLists.txt
+++ b/src/citra_qt/CMakeLists.txt
@@ -14,7 +14,7 @@ set(SRCS
config/controller_config.cpp
config/controller_config_util.cpp)
-set (HEADERS
+set(HEADERS
bootmanager.hxx
debugger/callstack.hxx
debugger/disassembler.hxx
@@ -26,24 +26,30 @@ set (HEADERS
config/controller_config.hxx
config/controller_config_util.hxx)
-qt4_wrap_ui(UI_HDRS
- debugger/callstack.ui
- debugger/disassembler.ui
- debugger/registers.ui
- hotkeys.ui
- main.ui
- config/controller_config.ui)
+set(UIS
+ debugger/callstack.ui
+ debugger/disassembler.ui
+ debugger/registers.ui
+ hotkeys.ui
+ main.ui
+ config/controller_config.ui)
-# add uic results to include directories
-include_directories(${CMAKE_CURRENT_BINARY_DIR})
+if(USE_QT5)
+ qt5_wrap_ui(UI_HDRS ${UIS})
+else()
+ qt4_wrap_ui(UI_HDRS ${UIS})
+endif()
-add_executable(citra-qt ${SRCS} ${UI_HDRS})
-if (APPLE)
+add_executable(citra-qt ${SRCS} ${HEADERS} ${UI_HDRS})
+if(APPLE)
set(ICONV_LIBRARY iconv)
else()
set(RT_LIBRARY rt)
endif()
-target_link_libraries(citra-qt core common video_core qhexedit ${ICONV_LIBRARY} ${COREFOUNDATION_LIBRARY} ${QT_LIBRARIES} ${OPENGL_LIBRARIES} ${RT_LIBRARY} ${GLEW_LIBRARY} ${GLFW_LIBRARIES})
+target_link_libraries(citra-qt core common video_core qhexedit ${ICONV_LIBRARY} ${COREFOUNDATION_LIBRARY} ${QT_LIBRARIES} ${OPENGL_LIBRARIES} ${RT_LIBRARY} ${GLEW_LIBRARY})
+if(USE_QT5)
+ target_link_libraries(citra-qt Qt5::Gui Qt5::Widgets Qt5::OpenGL)
+endif()
#install(TARGETS citra-qt RUNTIME DESTINATION ${bindir})