summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorReinUsesLisp <reinuseslisp@airmail.cc>2021-07-19 01:56:50 +0200
committerameerj <52414509+ameerj@users.noreply.github.com>2021-07-23 03:51:40 +0200
commit4a82450c8139ee751f23f2d50bec6e748e7c9637 (patch)
tree64f936d17875a34ab7110085add9efbed2aca17f /src/common/CMakeLists.txt
parentshader: Fix disabled attribute default values (diff)
downloadyuzu-4a82450c8139ee751f23f2d50bec6e748e7c9637.tar
yuzu-4a82450c8139ee751f23f2d50bec6e748e7c9637.tar.gz
yuzu-4a82450c8139ee751f23f2d50bec6e748e7c9637.tar.bz2
yuzu-4a82450c8139ee751f23f2d50bec6e748e7c9637.tar.lz
yuzu-4a82450c8139ee751f23f2d50bec6e748e7c9637.tar.xz
yuzu-4a82450c8139ee751f23f2d50bec6e748e7c9637.tar.zst
yuzu-4a82450c8139ee751f23f2d50bec6e748e7c9637.zip
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index c92266a17..3e34c6c2d 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -1,8 +1,3 @@
-# Add a custom command to generate a new shader_cache_version hash when any of the following files change
-# NOTE: This is an approximation of what files affect shader generation, its possible something else
-# could affect the result, but much more unlikely than the following files. Keeping a list of files
-# like this allows for much better caching since it doesn't force the user to recompile binary shaders every update
-set(VIDEO_CORE "${CMAKE_SOURCE_DIR}/src/video_core")
if (DEFINED ENV{AZURECIREPO})
set(BUILD_REPOSITORY $ENV{AZURECIREPO})
endif()
@@ -30,10 +25,7 @@ add_custom_command(OUTPUT scm_rev.cpp
-DGIT_EXECUTABLE=${GIT_EXECUTABLE}
-P ${CMAKE_SOURCE_DIR}/CMakeModules/GenerateSCMRev.cmake
DEPENDS
- # WARNING! It was too much work to try and make a common location for this list,
- # so if you need to change it, please update CMakeModules/GenerateSCMRev.cmake as well
- # ...
- # and also check that the scm_rev files haven't changed
+ # Check that the scm_rev files haven't changed
"${CMAKE_CURRENT_SOURCE_DIR}/scm_rev.cpp.in"
"${CMAKE_CURRENT_SOURCE_DIR}/scm_rev.h"
# technically we should regenerate if the git version changed, but its not worth the effort imo