summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2014-10-28 08:36:00 +0100
committerYuri Kunde Schlesner <yuriks@yuriks.net>2014-12-13 04:59:52 +0100
commit616d87444313db865c60fbeee36ebe5250ef301e (patch)
treefb99bf8bebfdf8c825c5d3e4f01fb4779ceaba68 /src/common/CMakeLists.txt
parentAdd SCOPE_EXIT macro to conveniently execute cleanup actions (diff)
downloadyuzu-616d87444313db865c60fbeee36ebe5250ef301e.tar
yuzu-616d87444313db865c60fbeee36ebe5250ef301e.tar.gz
yuzu-616d87444313db865c60fbeee36ebe5250ef301e.tar.bz2
yuzu-616d87444313db865c60fbeee36ebe5250ef301e.tar.lz
yuzu-616d87444313db865c60fbeee36ebe5250ef301e.tar.xz
yuzu-616d87444313db865c60fbeee36ebe5250ef301e.tar.zst
yuzu-616d87444313db865c60fbeee36ebe5250ef301e.zip
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 1dbc5db21..7c1d3d1dc 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -11,6 +11,8 @@ set(SRCS
hash.cpp
key_map.cpp
log_manager.cpp
+ logging/text_formatter.cpp
+ logging/backend.cpp
math_util.cpp
mem_arena.cpp
memory_util.cpp
@@ -32,6 +34,7 @@ set(HEADERS
common_funcs.h
common_paths.h
common_types.h
+ concurrent_ring_buffer.h
console_listener.h
cpu_detect.h
debug_interface.h
@@ -45,6 +48,9 @@ set(HEADERS
linear_disk_cache.h
log.h
log_manager.h
+ logging/text_formatter.h
+ logging/log.h
+ logging/backend.h
math_util.h
mem_arena.h
memory_util.h