summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorFernando Sahmkow <fsahmkow27@gmail.com>2020-05-30 03:38:34 +0200
committerGitHub <noreply@github.com>2020-05-30 03:38:34 +0200
commit9d9ffe0f9461ffa3b2e183b17a08953ada0ee91b (patch)
tree8349fdcf0167f5ee4534aa3a679fc872d4d604f1 /src/common/CMakeLists.txt
parentMerge pull request #4007 from ReinUsesLisp/reduce-logs (diff)
parentAdd xbyak external (diff)
downloadyuzu-9d9ffe0f9461ffa3b2e183b17a08953ada0ee91b.tar
yuzu-9d9ffe0f9461ffa3b2e183b17a08953ada0ee91b.tar.gz
yuzu-9d9ffe0f9461ffa3b2e183b17a08953ada0ee91b.tar.bz2
yuzu-9d9ffe0f9461ffa3b2e183b17a08953ada0ee91b.tar.lz
yuzu-9d9ffe0f9461ffa3b2e183b17a08953ada0ee91b.tar.xz
yuzu-9d9ffe0f9461ffa3b2e183b17a08953ada0ee91b.tar.zst
yuzu-9d9ffe0f9461ffa3b2e183b17a08953ada0ee91b.zip
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 264dff546..24b7a083c 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -171,10 +171,12 @@ if(ARCHITECTURE_x86_64)
PRIVATE
x64/cpu_detect.cpp
x64/cpu_detect.h
+ x64/xbyak_abi.h
+ x64/xbyak_util.h
)
endif()
create_target_directory_groups(common)
target_link_libraries(common PUBLIC Boost::boost fmt::fmt microprofile)
-target_link_libraries(common PRIVATE lz4::lz4 zstd::zstd)
+target_link_libraries(common PRIVATE lz4::lz4 zstd::zstd xbyak)