summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2015-07-22 04:54:38 +0200
committerbunnei <bunneidev@gmail.com>2015-08-15 23:33:46 +0200
commitd67e2f78b77c0739caa8c6a915685aa8961a519c (patch)
tree6973754fc51ceb01efecd8618150084fd0608487 /src/common/CMakeLists.txt
parentCommon: Ported over boilerplate x86 JIT code from Dolphin/PPSSPP. (diff)
downloadyuzu-d67e2f78b77c0739caa8c6a915685aa8961a519c.tar
yuzu-d67e2f78b77c0739caa8c6a915685aa8961a519c.tar.gz
yuzu-d67e2f78b77c0739caa8c6a915685aa8961a519c.tar.bz2
yuzu-d67e2f78b77c0739caa8c6a915685aa8961a519c.tar.lz
yuzu-d67e2f78b77c0739caa8c6a915685aa8961a519c.tar.xz
yuzu-d67e2f78b77c0739caa8c6a915685aa8961a519c.tar.zst
yuzu-d67e2f78b77c0739caa8c6a915685aa8961a519c.zip
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 600193858..af387c6c8 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -6,6 +6,7 @@ set(SRCS
break_points.cpp
emu_window.cpp
file_util.cpp
+ hash.cpp
key_map.cpp
logging/filter.cpp
logging/text_formatter.cpp
@@ -35,6 +36,7 @@ set(HEADERS
debug_interface.h
emu_window.h
file_util.h
+ hash.h
key_map.h
linear_disk_cache.h
logging/text_formatter.h
@@ -59,7 +61,7 @@ set(HEADERS
vector_math.h
)
-if(_M_X86)
+if(_M_X86_64)
set(SRCS ${SRCS}
cpu_detect_x86.cpp
x64_emitter.cpp)