summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authort895 <clombardo169@gmail.com>2024-02-17 03:19:17 +0100
committert895 <clombardo169@gmail.com>2024-02-17 18:32:33 +0100
commit50ecad547ea7e88301583f17c9f1eea2cc75b0af (patch)
tree21e6a6669ea19d05b389b097c0d411654aba4fbf /src/input_common/CMakeLists.txt
parenthid_core: Prevent crash if we try to iterate through empty color devices list (diff)
downloadyuzu-50ecad547ea7e88301583f17c9f1eea2cc75b0af.tar
yuzu-50ecad547ea7e88301583f17c9f1eea2cc75b0af.tar.gz
yuzu-50ecad547ea7e88301583f17c9f1eea2cc75b0af.tar.bz2
yuzu-50ecad547ea7e88301583f17c9f1eea2cc75b0af.tar.lz
yuzu-50ecad547ea7e88301583f17c9f1eea2cc75b0af.tar.xz
yuzu-50ecad547ea7e88301583f17c9f1eea2cc75b0af.tar.zst
yuzu-50ecad547ea7e88301583f17c9f1eea2cc75b0af.zip
Diffstat (limited to '')
-rw-r--r--src/input_common/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index d0a71a15b..d455323e0 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -2,8 +2,6 @@
# SPDX-License-Identifier: GPL-2.0-or-later
add_library(input_common STATIC
- drivers/android.cpp
- drivers/android.h
drivers/camera.cpp
drivers/camera.h
drivers/keyboard.cpp
@@ -94,3 +92,11 @@ target_link_libraries(input_common PUBLIC hid_core PRIVATE common Boost::headers
if (YUZU_USE_PRECOMPILED_HEADERS)
target_precompile_headers(input_common PRIVATE precompiled_headers.h)
endif()
+
+if (ANDROID)
+ target_sources(input_common PRIVATE
+ drivers/android.cpp
+ drivers/android.h
+ )
+ target_link_libraries(input_common PRIVATE android)
+endif()