summaryrefslogtreecommitdiffstats
path: root/src/shader_recompiler/CMakeLists.txt
diff options
context:
space:
mode:
authorReinUsesLisp <reinuseslisp@airmail.cc>2021-02-06 03:11:23 +0100
committerameerj <52414509+ameerj@users.noreply.github.com>2021-07-23 03:51:21 +0200
commit16cb00c521cae6e93ec49d10e15b575b7bc4857e (patch)
tree3b283895510af56fced7e62031c6beda999c0a1c /src/shader_recompiler/CMakeLists.txt
parentshader: Make typed IR (diff)
downloadyuzu-16cb00c521cae6e93ec49d10e15b575b7bc4857e.tar
yuzu-16cb00c521cae6e93ec49d10e15b575b7bc4857e.tar.gz
yuzu-16cb00c521cae6e93ec49d10e15b575b7bc4857e.tar.bz2
yuzu-16cb00c521cae6e93ec49d10e15b575b7bc4857e.tar.lz
yuzu-16cb00c521cae6e93ec49d10e15b575b7bc4857e.tar.xz
yuzu-16cb00c521cae6e93ec49d10e15b575b7bc4857e.tar.zst
yuzu-16cb00c521cae6e93ec49d10e15b575b7bc4857e.zip
Diffstat (limited to '')
-rw-r--r--src/shader_recompiler/CMakeLists.txt14
1 files changed, 9 insertions, 5 deletions
diff --git a/src/shader_recompiler/CMakeLists.txt b/src/shader_recompiler/CMakeLists.txt
index 72d5f41d2..248e90d4b 100644
--- a/src/shader_recompiler/CMakeLists.txt
+++ b/src/shader_recompiler/CMakeLists.txt
@@ -1,4 +1,5 @@
add_executable(shader_recompiler
+ backend/spirv/emit_spirv.h
environment.h
exception.h
file_environment.cpp
@@ -17,10 +18,12 @@ add_executable(shader_recompiler
frontend/ir/ir_emitter.h
frontend/ir/microinstruction.cpp
frontend/ir/microinstruction.h
- frontend/ir/opcode.cpp
- frontend/ir/opcode.h
- frontend/ir/opcode.inc
+ frontend/ir/opcodes.cpp
+ frontend/ir/opcodes.h
+ frontend/ir/opcodes.inc
frontend/ir/pred.h
+ frontend/ir/program.cpp
+ frontend/ir/program.h
frontend/ir/reg.h
frontend/ir/type.cpp
frontend/ir/type.h
@@ -33,8 +36,8 @@ add_executable(shader_recompiler
frontend/maxwell/instruction.h
frontend/maxwell/location.h
frontend/maxwell/maxwell.inc
- frontend/maxwell/opcode.cpp
- frontend/maxwell/opcode.h
+ frontend/maxwell/opcodes.cpp
+ frontend/maxwell/opcodes.h
frontend/maxwell/program.cpp
frontend/maxwell/program.h
frontend/maxwell/termination_code.cpp
@@ -67,6 +70,7 @@ add_executable(shader_recompiler
ir_opt/ssa_rewrite_pass.cpp
ir_opt/verification_pass.cpp
main.cpp
+ object_pool.h
)
target_link_libraries(shader_recompiler PRIVATE fmt::fmt)