summaryrefslogtreecommitdiffstats
path: root/src/shader_recompiler/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <22451773+lat9nq@users.noreply.github.com>2021-04-10 08:32:55 +0200
committerameerj <52414509+ameerj@users.noreply.github.com>2021-07-23 03:51:26 +0200
commit5bfcafa0a21619e8cd82c38ec51e260838f42042 (patch)
tree05b34d95d2a32ef58ae76519610b002baa9f7adc /src/shader_recompiler/CMakeLists.txt
parentshader_recompiler,video_core: Cleanup some GCC and Clang errors (diff)
downloadyuzu-5bfcafa0a21619e8cd82c38ec51e260838f42042.tar
yuzu-5bfcafa0a21619e8cd82c38ec51e260838f42042.tar.gz
yuzu-5bfcafa0a21619e8cd82c38ec51e260838f42042.tar.bz2
yuzu-5bfcafa0a21619e8cd82c38ec51e260838f42042.tar.lz
yuzu-5bfcafa0a21619e8cd82c38ec51e260838f42042.tar.xz
yuzu-5bfcafa0a21619e8cd82c38ec51e260838f42042.tar.zst
yuzu-5bfcafa0a21619e8cd82c38ec51e260838f42042.zip
Diffstat (limited to '')
-rw-r--r--src/shader_recompiler/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/shader_recompiler/CMakeLists.txt b/src/shader_recompiler/CMakeLists.txt
index 551bf1c58..6b5df23e2 100644
--- a/src/shader_recompiler/CMakeLists.txt
+++ b/src/shader_recompiler/CMakeLists.txt
@@ -197,6 +197,8 @@ else()
$<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-variable>
-Werror=unused-variable
+ # Bracket depth determines maximum size of a fold expression in Clang since 9c9974c3ccb6.
+ # And this in turns limits the size of a std::array.
$<$<CXX_COMPILER_ID:Clang>:-fbracket-depth=1024>
)
endif()