summaryrefslogtreecommitdiffstats
path: root/src/yuzu_cmd/CMakeLists.txt
diff options
context:
space:
mode:
authorReinUsesLisp <reinuseslisp@airmail.cc>2020-01-21 20:40:53 +0100
committerReinUsesLisp <reinuseslisp@airmail.cc>2020-01-29 21:53:11 +0100
commitf92cbc55018b5a3d98dd2093354f20c62ace5fda (patch)
tree7ec9af0d8820b45de580c2d608fdb1853485db83 /src/yuzu_cmd/CMakeLists.txt
parentweb_service/telemetry_json: Report USER_CONFIG (diff)
downloadyuzu-f92cbc55018b5a3d98dd2093354f20c62ace5fda.tar
yuzu-f92cbc55018b5a3d98dd2093354f20c62ace5fda.tar.gz
yuzu-f92cbc55018b5a3d98dd2093354f20c62ace5fda.tar.bz2
yuzu-f92cbc55018b5a3d98dd2093354f20c62ace5fda.tar.lz
yuzu-f92cbc55018b5a3d98dd2093354f20c62ace5fda.tar.xz
yuzu-f92cbc55018b5a3d98dd2093354f20c62ace5fda.tar.zst
yuzu-f92cbc55018b5a3d98dd2093354f20c62ace5fda.zip
Diffstat (limited to '')
-rw-r--r--src/yuzu_cmd/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/yuzu_cmd/CMakeLists.txt b/src/yuzu_cmd/CMakeLists.txt
index b5f06ab9e..a15719a0f 100644
--- a/src/yuzu_cmd/CMakeLists.txt
+++ b/src/yuzu_cmd/CMakeLists.txt
@@ -8,11 +8,22 @@ add_executable(yuzu-cmd
emu_window/emu_window_sdl2_gl.h
emu_window/emu_window_sdl2.cpp
emu_window/emu_window_sdl2.h
+ emu_window/emu_window_sdl2_gl.cpp
+ emu_window/emu_window_sdl2_gl.h
resource.h
yuzu.cpp
yuzu.rc
)
+if (ENABLE_VULKAN)
+ target_sources(yuzu-cmd PRIVATE
+ emu_window/emu_window_sdl2_vk.cpp
+ emu_window/emu_window_sdl2_vk.h)
+
+ target_include_directories(yuzu-cmd PRIVATE ../../externals/Vulkan-Headers/include)
+ target_compile_definitions(yuzu-cmd PRIVATE HAS_VULKAN)
+endif()
+
create_target_directory_groups(yuzu-cmd)
target_link_libraries(yuzu-cmd PRIVATE common core input_common)