summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b619e06fb..55880990c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -190,17 +190,11 @@ if (ENABLE_QT)
if (DEFINED QT_VER)
download_bundled_external("qt/" ${QT_VER} QT_PREFIX)
endif()
- elseif (DEFINED ENV{QTDIR})
- # Set CMAKE_PREFIX_PATH if QTDIR is defined in the environment This allows CMake to
- # automatically find the Qt packages on Windows
- set(QT_PREFIX "$ENV{QTDIR}")
- endif()
- # Passing an empty HINTS seems to cause default system paths to get ignored in CMake 2.8 so make
- # sure to not pass anything if we don't have one
- if (DEFINED QT_PREFIX)
set(QT_PREFIX_HINT HINTS "${QT_PREFIX}")
else()
+ # Passing an empty HINTS seems to cause default system paths to get ignored in CMake 2.8 so
+ # make sure to not pass anything if we don't have one.
set(QT_PREFIX_HINT)
endif()