summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 238e92dcc..b746554fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -171,6 +171,13 @@ if (ENABLE_SDL2)
else()
find_package(SDL2 REQUIRED)
endif()
+
+ if (SDL2_FOUND)
+ # TODO(yuriks): Make FindSDL2.cmake export an IMPORTED library instead
+ add_library(SDL2 INTERFACE)
+ target_link_libraries(SDL2 INTERFACE "${SDL2_LIBRARY}")
+ target_include_directories(SDL2 INTERFACE "${SDL2_INCLUDE_DIR}")
+ endif()
else()
set(SDL2_FOUND NO)
endif()