summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 478246b6f..1cfd3bbc9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -64,8 +64,10 @@ if (MSVC)
else()
add_compile_options(
-Wall
+ -Werror=array-bounds
-Werror=implicit-fallthrough
-Werror=missing-declarations
+ -Werror=missing-field-initializers
-Werror=reorder
-Werror=switch
-Werror=uninitialized