summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 4b30185f1..7e83e64b0 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -27,7 +27,6 @@ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/scm_rev.cpp.in" "${CMAKE_CURRENT_SOU
set(SRCS
break_points.cpp
file_util.cpp
- framebuffer_layout.cpp
hash.cpp
logging/filter.cpp
logging/text_formatter.cpp
@@ -38,6 +37,7 @@ set(SRCS
param_package.cpp
scm_rev.cpp
string_util.cpp
+ telemetry.cpp
thread.cpp
timer.cpp
)
@@ -55,7 +55,6 @@ set(HEADERS
common_paths.h
common_types.h
file_util.h
- framebuffer_layout.h
hash.h
linear_disk_cache.h
logging/text_formatter.h
@@ -74,6 +73,7 @@ set(HEADERS
string_util.h
swap.h
synchronized_wrapper.h
+ telemetry.h
thread.h
thread_queue_list.h
timer.h
@@ -95,6 +95,7 @@ endif()
create_directory_groups(${SRCS} ${HEADERS})
add_library(common STATIC ${SRCS} ${HEADERS})
+target_link_libraries(common PUBLIC Boost::boost microprofile)
if (ARCHITECTURE_x86_64)
- target_link_libraries(common xbyak)
+ target_link_libraries(common PRIVATE xbyak)
endif()