summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2016-07-17 16:23:29 +0200
committerMattes D <github@xoft.cz>2016-07-18 22:11:41 +0200
commit430b62322355c0bfe6233586c9823013d60a3335 (patch)
treeed6adc62f2a7e2a5b2d39056eac962ec5a680cb5 /CMakeLists.txt
parentAPIDump: Added explicit IsStatic flag to static functions. (diff)
downloadcuberite-430b62322355c0bfe6233586c9823013d60a3335.tar
cuberite-430b62322355c0bfe6233586c9823013d60a3335.tar.gz
cuberite-430b62322355c0bfe6233586c9823013d60a3335.tar.bz2
cuberite-430b62322355c0bfe6233586c9823013d60a3335.tar.lz
cuberite-430b62322355c0bfe6233586c9823013d60a3335.tar.xz
cuberite-430b62322355c0bfe6233586c9823013d60a3335.tar.zst
cuberite-430b62322355c0bfe6233586c9823013d60a3335.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 02de722bb..f5ea75ba5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,6 +92,18 @@ endif()
set(BUILD_TOOLS OFF CACHE BOOL "")
set(SELF_TEST OFF CACHE BOOL "")
+# Check whether Lua 5.1 is installed locally:
+include(CheckLua.cmake)
+if(HAS_LUA_INTERPRETER AND ("${LUA_INTERPRETER_VERSION}" STREQUAL "5.1"))
+ message(STATUS "Lua 5.1 has been found in your system and will be used for the build.")
+else()
+ if (CROSSCOMPILE)
+ message(FATAL "To crosscompile, you need to have Lua 5.1 installed in your system and available in PATH.")
+ endif()
+ message(STATUS "Lua 5.1 has NOT been found in your system, the build will use its own Lua implementation.")
+endif()
+
+
# This has to be done before any flags have been set up.
if(${BUILD_TOOLS})
message("Building tools")