summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2015-06-18 23:30:41 +0200
committerMattes D <github@xoft.cz>2015-06-19 16:15:59 +0200
commit8df31067d4703beb3225b7d9787385d58f893c5d (patch)
treeab6863dece3d5741b8ea1989700f29188a4f8098 /CMakeLists.txt
parentPrefabPiecePool: Added loading from cubeset file. (diff)
downloadcuberite-8df31067d4703beb3225b7d9787385d58f893c5d.tar
cuberite-8df31067d4703beb3225b7d9787385d58f893c5d.tar.gz
cuberite-8df31067d4703beb3225b7d9787385d58f893c5d.tar.bz2
cuberite-8df31067d4703beb3225b7d9787385d58f893c5d.tar.lz
cuberite-8df31067d4703beb3225b7d9787385d58f893c5d.tar.xz
cuberite-8df31067d4703beb3225b7d9787385d58f893c5d.tar.zst
cuberite-8df31067d4703beb3225b7d9787385d58f893c5d.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt50
1 files changed, 45 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 53e836262..db397a2d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -197,13 +197,53 @@ if(${SELF_TEST})
add_subdirectory (tests)
endif()
-# Put project into solution folders in MSVC:
+# Put projects into solution folders in MSVC:
if (MSVC)
- set_target_properties(event_core event_extra expat jsoncpp lua luaexpat mbedtls sqlite SQLiteCpp tolualib zlib PROPERTIES FOLDER Lib)
- set_target_properties(luaproxy tolua PROPERTIES FOLDER Support)
+ set_target_properties(
+ event_core
+ event_extra
+ expat
+ jsoncpp
+ lua
+ luaexpat
+ mbedtls
+ sqlite
+ SQLiteCpp
+ tolualib
+ zlib
+ PROPERTIES FOLDER Lib
+ )
+ set_target_properties(
+ luaproxy
+ tolua
+ PROPERTIES FOLDER Support
+ )
if (${SELF_TEST})
- set_target_properties(Network PROPERTIES FOLDER Lib)
- set_target_properties(arraystocoords-exe coordinates-exe copies-exe copyblocks-exe creatable-exe EchoServer Google-exe ChunkBuffer NameLookup PROPERTIES FOLDER Tests)
+ set_target_properties(
+ Network
+ PROPERTIES FOLDER Lib
+ )
+ set_target_properties(
+ arraystocoords-exe
+ ChunkBuffer
+ coordinates-exe
+ copies-exe
+ copyblocks-exe
+ creatable-exe
+ EchoServer
+ Google-exe
+ LoadablePieces
+ NameLookup
+ PROPERTIES FOLDER Tests
+ )
+ endif()
+
+ if(${BUILD_TOOLS})
+ set_target_properties(
+ MCADefrag
+ ProtoProxy
+ PROPERTIES FOLDER Tools
+ )
endif()
endif()