summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormadmaxoft <github@xoft.cz>2014-01-22 22:19:33 +0100
committermadmaxoft <github@xoft.cz>2014-01-22 22:19:33 +0100
commiteb9bebf7558e56aab10307afc59824c728b6206f (patch)
tree610a7aac9b71f1d500149f4a87b5a8de63dfbab8 /CMakeLists.txt
parentAdded PolarSSL as a submodule. (diff)
downloadcuberite-eb9bebf7558e56aab10307afc59824c728b6206f.tar
cuberite-eb9bebf7558e56aab10307afc59824c728b6206f.tar.gz
cuberite-eb9bebf7558e56aab10307afc59824c728b6206f.tar.bz2
cuberite-eb9bebf7558e56aab10307afc59824c728b6206f.tar.lz
cuberite-eb9bebf7558e56aab10307afc59824c728b6206f.tar.xz
cuberite-eb9bebf7558e56aab10307afc59824c728b6206f.tar.zst
cuberite-eb9bebf7558e56aab10307afc59824c728b6206f.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ddd34db3..a10db7d49 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -183,7 +183,6 @@ project (MCServer)
# Include all the libraries:
add_subdirectory(lib/inifile/)
add_subdirectory(lib/jsoncpp/)
-add_subdirectory(lib/cryptopp/)
add_subdirectory(lib/zlib/)
add_subdirectory(lib/lua/)
add_subdirectory(lib/tolua++/)
@@ -192,6 +191,12 @@ add_subdirectory(lib/expat/)
add_subdirectory(lib/luaexpat/)
add_subdirectory(lib/md5/)
+
+# We use EXCLUDE_FROM_ALL so that only the explicit dependencies are used
+# (PolarSSL also has test and example programs in their CMakeLists.txt, we don't want those)
+add_subdirectory(lib/polarssl/ EXCLUDE_FROM_ALL)
+
+
# Remove disabling the maximum warning level:
# clang does not like a command line that reads -Wall -Wextra -w -Wall -Wextra and does not output any warnings
# We do not do that for MSVC since MSVC produces an awful lot of warnings for its own STL headers;