summaryrefslogtreecommitdiffstats
path: root/src/HTTPServer/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2016-03-01 16:58:43 +0100
committerMattes D <github@xoft.cz>2016-03-01 16:58:43 +0100
commit7cc8f8dd2213cade66633d196f579895385a869a (patch)
tree83219a6eaf87a2050c10662fb8caa5d1514a6af4 /src/HTTPServer/CMakeLists.txt
parentMerge pull request #3057 from tonibm19/master (diff)
parentHTTP: Fixed typos and bad leftovers. (diff)
downloadcuberite-7cc8f8dd2213cade66633d196f579895385a869a.tar
cuberite-7cc8f8dd2213cade66633d196f579895385a869a.tar.gz
cuberite-7cc8f8dd2213cade66633d196f579895385a869a.tar.bz2
cuberite-7cc8f8dd2213cade66633d196f579895385a869a.tar.lz
cuberite-7cc8f8dd2213cade66633d196f579895385a869a.tar.xz
cuberite-7cc8f8dd2213cade66633d196f579895385a869a.tar.zst
cuberite-7cc8f8dd2213cade66633d196f579895385a869a.zip
Diffstat (limited to 'src/HTTPServer/CMakeLists.txt')
-rw-r--r--src/HTTPServer/CMakeLists.txt39
1 files changed, 0 insertions, 39 deletions
diff --git a/src/HTTPServer/CMakeLists.txt b/src/HTTPServer/CMakeLists.txt
deleted file mode 100644
index a08a1fcf8..000000000
--- a/src/HTTPServer/CMakeLists.txt
+++ /dev/null
@@ -1,39 +0,0 @@
-
-cmake_minimum_required (VERSION 2.6)
-project (Cuberite)
-
-include_directories ("${PROJECT_SOURCE_DIR}/../")
-
-SET (SRCS
- EnvelopeParser.cpp
- HTTPConnection.cpp
- HTTPFormParser.cpp
- HTTPMessage.cpp
- HTTPServer.cpp
- MultipartParser.cpp
- NameValueParser.cpp
- SslHTTPConnection.cpp
- UrlParser.cpp
-)
-
-SET (HDRS
- EnvelopeParser.h
- HTTPConnection.h
- HTTPFormParser.h
- HTTPMessage.h
- HTTPServer.h
- MultipartParser.h
- NameValueParser.h
- SslHTTPConnection.h
- UrlParser.h
-)
-
-if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- set_source_files_properties(HTTPServer.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=global-constructors ")
- set_source_files_properties(HTTPConnection.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=switch-enum")
- set_source_files_properties(HTTPMessage.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=tautological-compare")
-endif()
-
-if(NOT MSVC)
- add_library(HTTPServer ${SRCS} ${HDRS})
-endif()