summaryrefslogtreecommitdiffstats
path: root/tests/Generating/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2017-03-22 14:05:28 +0100
committerMattes D <github@xoft.cz>2017-05-04 09:49:30 +0200
commitc939720c103c6d4eac8a36cd26639b5b4b9f05cd (patch)
tree2990dcef8ebfda89e32b0a8cb0e567994077fb56 /tests/Generating/CMakeLists.txt
parentGen: Moved tests to a separate folder, unified shared sources. (diff)
downloadcuberite-c939720c103c6d4eac8a36cd26639b5b4b9f05cd.tar
cuberite-c939720c103c6d4eac8a36cd26639b5b4b9f05cd.tar.gz
cuberite-c939720c103c6d4eac8a36cd26639b5b4b9f05cd.tar.bz2
cuberite-c939720c103c6d4eac8a36cd26639b5b4b9f05cd.tar.lz
cuberite-c939720c103c6d4eac8a36cd26639b5b4b9f05cd.tar.xz
cuberite-c939720c103c6d4eac8a36cd26639b5b4b9f05cd.tar.zst
cuberite-c939720c103c6d4eac8a36cd26639b5b4b9f05cd.zip
Diffstat (limited to 'tests/Generating/CMakeLists.txt')
-rw-r--r--tests/Generating/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/Generating/CMakeLists.txt b/tests/Generating/CMakeLists.txt
index 4efb9dbe2..269ab50ab 100644
--- a/tests/Generating/CMakeLists.txt
+++ b/tests/Generating/CMakeLists.txt
@@ -112,10 +112,24 @@ add_test(NAME PieceRotation-test WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} C
+# PieceGeneratorBFSTree test:
+add_executable(PieceGeneratorBFSTree
+ PieceGeneratorBFSTreeTest.cpp
+ ${CMAKE_SOURCE_DIR}/src/Generating/PieceGeneratorBFSTree.cpp
+ ${CMAKE_SOURCE_DIR}/src/Generating/PieceGeneratorBFSTree.h
+)
+target_link_libraries(PieceGeneratorBFSTree GeneratorTestingSupport)
+add_test(NAME PieceGeneratorBFSTree-test WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/Server/Prefabs/PieceStructures COMMAND PieceGeneratorBFSTree)
+
+
+
+
+
# Put the projects into solution folders (MSVC):
set_target_properties(
GeneratorTestingSupport
LoadablePieces
+ PieceGeneratorBFSTree
PieceRotation
PROPERTIES FOLDER Tests/Generating
)