summaryrefslogtreecommitdiffstats
path: root/Tools/MCADefrag/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tools/MCADefrag/CMakeLists.txt')
-rw-r--r--Tools/MCADefrag/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/Tools/MCADefrag/CMakeLists.txt b/Tools/MCADefrag/CMakeLists.txt
index 700310edc..a4096791d 100644
--- a/Tools/MCADefrag/CMakeLists.txt
+++ b/Tools/MCADefrag/CMakeLists.txt
@@ -11,8 +11,9 @@ set_flags()
set_lib_flags()
enable_profile()
-
-
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ add_flags_cxx("-Wno-error=sign-conversion -Wno-error=conversion -Wno-error=shorten-64-to-32")
+endif()
# Set include paths to the used libraries:
include_directories("../../lib")