summaryrefslogtreecommitdiffstats
path: root/Tools/ProtoProxy/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tools/ProtoProxy/CMakeLists.txt')
-rw-r--r--Tools/ProtoProxy/CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/Tools/ProtoProxy/CMakeLists.txt b/Tools/ProtoProxy/CMakeLists.txt
index 431c29daa..8f3228a47 100644
--- a/Tools/ProtoProxy/CMakeLists.txt
+++ b/Tools/ProtoProxy/CMakeLists.txt
@@ -1,11 +1,8 @@
project (ProtoProxy)
+find_package(Threads REQUIRED)
include(../../SetFlags.cmake)
-set_flags()
-set_lib_flags()
-
-
# Set include paths to the used libraries:
include_directories(SYSTEM "../../lib")
include_directories(SYSTEM "../../lib/mbedtls/include")
@@ -22,8 +19,6 @@ endfunction()
add_subdirectory(../../lib/zlib ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_FILES_DIRECTORY}/lib/zlib)
-set_exe_flags()
-
# Include the shared files:
set(SHARED_SRC
../../src/ByteBuffer.cpp
@@ -99,5 +94,5 @@ add_executable(ProtoProxy
${SHARED_OSS_HDR}
)
-target_link_libraries(ProtoProxy zlib mbedtls fmt::fmt)
+target_link_libraries(ProtoProxy zlib mbedtls fmt::fmt Threads::Threads)