summaryrefslogtreecommitdiffstats
path: root/src/OSSupport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/OSSupport/CMakeLists.txt')
-rw-r--r--src/OSSupport/CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/src/OSSupport/CMakeLists.txt b/src/OSSupport/CMakeLists.txt
index 62ad9c475..1b853c202 100644
--- a/src/OSSupport/CMakeLists.txt
+++ b/src/OSSupport/CMakeLists.txt
@@ -1,5 +1,6 @@
+target_sources(
+ ${CMAKE_PROJECT_NAME} PRIVATE
-SET (SRCS
CriticalSection.cpp
Errors.cpp
Event.cpp
@@ -16,9 +17,7 @@ SET (SRCS
TCPLinkImpl.cpp
UDPEndpointImpl.cpp
WinStackWalker.cpp
-)
-SET (HDRS
AtomicUniquePtr.h
CriticalSection.h
Errors.h
@@ -40,11 +39,3 @@ SET (HDRS
WinStackWalker.h
)
-if(NOT MSVC)
- add_library(OSSupport ${SRCS} ${HDRS})
- target_link_libraries(OSSupport fmt::fmt)
-
- if(NOT WIN32)
- target_link_libraries(OSSupport event_pthreads_static)
- endif()
-endif()