summaryrefslogtreecommitdiffstats
path: root/tests/HTTP/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/HTTP/CMakeLists.txt')
-rw-r--r--tests/HTTP/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/HTTP/CMakeLists.txt b/tests/HTTP/CMakeLists.txt
index 233e5c0cb..55552c095 100644
--- a/tests/HTTP/CMakeLists.txt
+++ b/tests/HTTP/CMakeLists.txt
@@ -58,3 +58,16 @@ add_test(NAME HTTPMessageParser_file-test3-2 COMMAND HTTPMessageParser_file-exe
# Test parsing the request file in 512-byte chunks (should process everything in a single call):
add_test(NAME HTTPMessageParser_file-test4-512 COMMAND HTTPMessageParser_file-exe HTTPRequest1.data 512)
+
+
+
+
+# Put all the tests into a solution folder (MSVC):
+set_target_properties(
+ HTTPMessageParser_file-exe
+ PROPERTIES FOLDER Tests
+)
+set_target_properties(
+ HTTP
+ PROPERTIES FOLDER Lib
+)