summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e6eedfe..a062cb5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -42,3 +42,14 @@ known_first_party = ['glucometerutils']
known_third_party = ['construct', 'hidapi', 'pyscsi', 'serial', 'usbmon']
[tool.setuptools_scm]
+
+[tool.pytest.ini_options]
+addopts = "--color=yes --ignore=setup.py -ra"
+timeout = 120
+norecursedirs = [
+ '.env',
+ '.git',
+ 'dist',
+ 'build',
+ 'venv',
+]