summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorBen <b-schaefer@posteo.de>2020-03-02 17:30:51 +0100
committerDiego Elio Pettenò <flameeyes@flameeyes.com>2020-03-08 00:35:40 +0100
commitf6ef81ccc052902a7b8dfa33d24af5c70ac08657 (patch)
treeab0f02ba3687c053bd0c8e4f11d2a862247ac5b4 /pyproject.toml
parentFreeStyle: fix keepalive message handling for non-Libre devices. (diff)
downloadglucometerutils-f6ef81ccc052902a7b8dfa33d24af5c70ac08657.tar
glucometerutils-f6ef81ccc052902a7b8dfa33d24af5c70ac08657.tar.gz
glucometerutils-f6ef81ccc052902a7b8dfa33d24af5c70ac08657.tar.bz2
glucometerutils-f6ef81ccc052902a7b8dfa33d24af5c70ac08657.tar.lz
glucometerutils-f6ef81ccc052902a7b8dfa33d24af5c70ac08657.tar.xz
glucometerutils-f6ef81ccc052902a7b8dfa33d24af5c70ac08657.tar.zst
glucometerutils-f6ef81ccc052902a7b8dfa33d24af5c70ac08657.zip
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..d1898d8
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,29 @@
+# NOTE: you have to use single-quoted strings in TOML for regular expressions.
+# It's the equivalent of r-strings in Python. Multiline strings are treated as
+# verbose regular expressions by Black. Use [ ] to denote a significant space
+# character.
+
+[tool.black]
+line-length = 88
+target-version = ['py35']
+exclude = '''
+/(
+ \.eggs
+ | \.git
+ | \.hg
+ | \.mypy_cache
+ | \.tox
+ | \.venv
+ | _build
+ | buck-out
+ | build
+ | dist
+)/
+'''
+
+[tool.isort]
+line_length = 88
+multi_line_output = 3
+include_trailing_comma = true
+known_first_party = ['glucometerutils']
+known_third_party = ['construct', 'hidapi', 'pyserial', 'pyscsi']