summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorArkadiusz Bulski <arek.bulski@gmail.com>2018-02-16 08:24:25 +0100
committerDiego Elio Pettenò <flameeyes@flameeyes.eu>2018-03-17 14:41:40 +0100
commit4819131ff81532c06c5eccc4c70135e72ca3f7c9 (patch)
tree2f401c51f90afee69939fb74f20c9542686cb5a9 /setup.py
parentconstruct: the construct API is significantly unstable, fix to 2.8.22 only. (diff)
downloadglucometerutils-4819131ff81532c06c5eccc4c70135e72ca3f7c9.tar
glucometerutils-4819131ff81532c06c5eccc4c70135e72ca3f7c9.tar.gz
glucometerutils-4819131ff81532c06c5eccc4c70135e72ca3f7c9.tar.bz2
glucometerutils-4819131ff81532c06c5eccc4c70135e72ca3f7c9.tar.lz
glucometerutils-4819131ff81532c06c5eccc4c70135e72ca3f7c9.tar.xz
glucometerutils-4819131ff81532c06c5eccc4c70135e72ca3f7c9.tar.zst
glucometerutils-4819131ff81532c06c5eccc4c70135e72ca3f7c9.zip
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 7 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index c9236fd..0a9f258 100644
--- a/setup.py
+++ b/setup.py
@@ -49,15 +49,15 @@ setup(
# These are all the drivers' dependencies. Optional dependencies are
# listed as mandatory for the feature.
'otultra2': ['pyserial'],
- 'otultraeasy': ['construct==2.8.22', 'pyserial'],
- 'otverio2015': ['construct==2.8.22', 'python-scsi'],
- 'otverioiq': ['construct==2.8.22', 'pyserial'],
- 'fsinsulinx': ['construct==2.8.22', 'hidapi'],
- 'fslibre': ['construct==2.8.22', 'hidapi'],
+ 'otultraeasy': ['construct', 'pyserial'],
+ 'otverio2015': ['construct', 'python-scsi'],
+ 'otverioiq': ['construct', 'pyserial'],
+ 'fsinsulinx': ['construct', 'hidapi'],
+ 'fslibre': ['construct', 'hidapi'],
'fsoptium': ['pyserial'],
- 'fsprecisionneo': ['construct==2.8.22', 'hidapi'],
+ 'fsprecisionneo': ['construct', 'hidapi'],
'accucheck_reports': [],
- 'sdcodefree': ['construct==2.8.22', 'pyserial'],
+ 'sdcodefree': ['construct', 'pyserial'],
},
entry_points = {
'console_scripts': [