summaryrefslogtreecommitdiffstats
path: root/g4f/gui/webview.spec
diff options
context:
space:
mode:
authorHeiner Lohaus <hlohaus@users.noreply.github.com>2024-03-15 14:55:53 +0100
committerHeiner Lohaus <hlohaus@users.noreply.github.com>2024-03-15 14:55:53 +0100
commitb7eee50930dbd782d7c068d1d29cd270b97bc741 (patch)
treebdaa4377a62352cf2641c67a6bc21f903b5c0ea1 /g4f/gui/webview.spec
parentAdd Pyinstaller support, Use curl_cffi in You provider (diff)
downloadgpt4free-b7eee50930dbd782d7c068d1d29cd270b97bc741.tar
gpt4free-b7eee50930dbd782d7c068d1d29cd270b97bc741.tar.gz
gpt4free-b7eee50930dbd782d7c068d1d29cd270b97bc741.tar.bz2
gpt4free-b7eee50930dbd782d7c068d1d29cd270b97bc741.tar.lz
gpt4free-b7eee50930dbd782d7c068d1d29cd270b97bc741.tar.xz
gpt4free-b7eee50930dbd782d7c068d1d29cd270b97bc741.tar.zst
gpt4free-b7eee50930dbd782d7c068d1d29cd270b97bc741.zip
Diffstat (limited to 'g4f/gui/webview.spec')
-rw-r--r--g4f/gui/webview.spec45
1 files changed, 45 insertions, 0 deletions
diff --git a/g4f/gui/webview.spec b/g4f/gui/webview.spec
new file mode 100644
index 00000000..360e264e
--- /dev/null
+++ b/g4f/gui/webview.spec
@@ -0,0 +1,45 @@
+# -*- mode: python ; coding: utf-8 -*-
+
+
+block_cipher = None
+
+
+a = Analysis(
+ ['webview.py'],
+ pathex=[],
+ binaries=[],
+ datas=[],
+ hiddenimports=[],
+ hookspath=[],
+ hooksconfig={},
+ runtime_hooks=[],
+ excludes=[],
+ win_no_prefer_redirects=False,
+ win_private_assemblies=False,
+ cipher=block_cipher,
+ noarchive=False,
+)
+pyz = PYZ(a.pure, a.zipped_data, cipher=block_cipher)
+
+exe = EXE(
+ pyz,
+ a.scripts,
+ a.binaries,
+ Tree('client', prefix='client'),
+ a.zipfiles,
+ a.datas,
+ [],
+ name='webview',
+ debug=False,
+ bootloader_ignore_signals=False,
+ strip=False,
+ upx=True,
+ upx_exclude=[],
+ runtime_tmpdir=None,
+ console=False,
+ disable_windowed_traceback=False,
+ argv_emulation=False,
+ target_arch=None,
+ codesign_identity=None,
+ entitlements_file=None,
+)