summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMIDORIBIN <aquarion123@gmail.com>2023-07-28 12:07:17 +0200
committerMIDORIBIN <aquarion123@gmail.com>2023-08-14 04:46:32 +0200
commitf6ef3cb2237d8c336e915ef77ddbe6f37934c4fd (patch)
treec8bc44917ea03909cf586140f984ff0814bc30ea /setup.py
parent~ | small fixes & new pypi version | v-0.0.1.9 (diff)
downloadgpt4free-f6ef3cb2237d8c336e915ef77ddbe6f37934c4fd.tar
gpt4free-f6ef3cb2237d8c336e915ef77ddbe6f37934c4fd.tar.gz
gpt4free-f6ef3cb2237d8c336e915ef77ddbe6f37934c4fd.tar.bz2
gpt4free-f6ef3cb2237d8c336e915ef77ddbe6f37934c4fd.tar.lz
gpt4free-f6ef3cb2237d8c336e915ef77ddbe6f37934c4fd.tar.xz
gpt4free-f6ef3cb2237d8c336e915ef77ddbe6f37934c4fd.tar.zst
gpt4free-f6ef3cb2237d8c336e915ef77ddbe6f37934c4fd.zip
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py41
1 files changed, 34 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 176c4941..336419bb 100644
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,20 @@
-from setuptools import setup, find_packages
import codecs
import os
+from setuptools import find_packages, setup
+
here = os.path.abspath(os.path.dirname(__file__))
with codecs.open(os.path.join(here, "README.md"), encoding="utf-8") as fh:
long_description = "\n" + fh.read()
-
-with open('requirements.txt') as f:
+
+with open("requirements.txt") as f:
required = f.read().splitlines()
-VERSION = '0.0.1.9'
-DESCRIPTION = 'The official gpt4free repository | various collection of powerful language models'
+VERSION = "0.0.1.9"
+DESCRIPTION = (
+ "The official gpt4free repository | various collection of powerful language models"
+)
# Setting up
setup(
@@ -24,7 +27,31 @@ setup(
long_description=long_description,
packages=find_packages(),
install_requires=required,
- keywords=['python', 'chatbot', 'reverse-engineering', 'openai', 'chatbots', 'gpt', 'language-model', 'gpt-3', 'gpt3', 'openai-api', 'gpt-4', 'gpt4', 'chatgpt', 'chatgpt-api', 'openai-chatgpt', 'chatgpt-free', 'chatgpt-4', 'chatgpt4','chatgpt4-api', 'free', 'free-gpt', 'gpt4free', 'g4f'],
+ keywords=[
+ "python",
+ "chatbot",
+ "reverse-engineering",
+ "openai",
+ "chatbots",
+ "gpt",
+ "language-model",
+ "gpt-3",
+ "gpt3",
+ "openai-api",
+ "gpt-4",
+ "gpt4",
+ "chatgpt",
+ "chatgpt-api",
+ "openai-chatgpt",
+ "chatgpt-free",
+ "chatgpt-4",
+ "chatgpt4",
+ "chatgpt4-api",
+ "free",
+ "free-gpt",
+ "gpt4free",
+ "g4f",
+ ],
classifiers=[
"Development Status :: 2 - Pre-Alpha",
"Intended Audience :: Developers",
@@ -32,5 +59,5 @@ setup(
"Operating System :: Unix",
"Operating System :: MacOS :: MacOS X",
"Operating System :: Microsoft :: Windows",
- ]
+ ],
)