summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml25
1 files changed, 17 insertions, 8 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 37ec92d2..7281f679 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -9,18 +9,27 @@ packages = [{ include = "gpt4free" }]
exclude = ["**/*.txt"]
[tool.poetry.dependencies]
-python = "^3.7"
-websocket-client = "^1.5.1"
-requests = "2.29.0"
-tls-client = "^0.2"
-pypasser = "^0.0.5"
-names = "^0.3.0"
+python = "^3.10"
+
colorama = "^0.4.6"
curl-cffi = "^0.5.5"
-selenium = "^4.9.0"
fake-useragent = "^1.1.3"
-twocaptcha = "^0.0.1"
+Levenshtein = "*"
+mailgw_temporary_email = "*"
+names = "^0.3.0"
+pycryptodome = "*"
pydantic = "^1.10.7"
+pypasser = "^0.0.5"
+pymailtm = "*"
+random-password-generator = "*"
+requests = "^2.29.0"
+retrying = "*"
+selenium = "^4.9.0"
+streamlit-chat = { git = "https://github.com/AI-Yash/st-chat", rev = "ffb0583" }
+streamlit = "^1.21.0"
+tls-client = "^0.2"
+twocaptcha = "^0.0.1"
+websocket-client = "^1.5.1"
[build-system]