summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 00000000..10718ffa
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,21 @@
+[build-system]
+requires = ["setuptools", "wheel"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "gpt4free"
+version = "0.2.0"
+description = ""
+authors = []
+license = { text = "GPL-3.0" }
+readme = "README.md"
+requires-python = ">=3.10"
+dynamic = ["dependencies"]
+
+[tool.setuptools.packages.find]
+exclude = ["**/*.txt", "/.v1/*"]
+include = ["g4f"]
+
+
+[tool.setuptools.dynamic]
+dependencies = {file = ["requirements.txt"]} \ No newline at end of file