summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFilip Gawin <filip.gawin@zoho.com>2021-02-12 02:04:31 +0100
committererorcun <erorcunerorcun@hotmail.com.tr>2021-02-12 19:09:46 +0100
commit0c60ceeb33c06c17b35773ca4095c2d4c342a0dc (patch)
tree167934e328d12c31cd1d058c03411c60b38b3f0d /CMakeLists.txt
parentRemove version text, add toggleable debug info(with commit hash!) (diff)
downloadre3-0c60ceeb33c06c17b35773ca4095c2d4c342a0dc.tar
re3-0c60ceeb33c06c17b35773ca4095c2d4c342a0dc.tar.gz
re3-0c60ceeb33c06c17b35773ca4095c2d4c342a0dc.tar.bz2
re3-0c60ceeb33c06c17b35773ca4095c2d4c342a0dc.tar.lz
re3-0c60ceeb33c06c17b35773ca4095c2d4c342a0dc.tar.xz
re3-0c60ceeb33c06c17b35773ca4095c2d4c342a0dc.tar.zst
re3-0c60ceeb33c06c17b35773ca4095c2d4c342a0dc.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7282135d..e8689b38 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,10 @@ set(PROJECT REVC)
project(${EXECUTABLE} C CXX)
list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/cmake")
+include(GetGitRevisionDescription)
+get_git_head_revision(GIT_REFSPEC GIT_SHA1 "ALLOW_LOOKING_ABOVE_CMAKE_SOURCE_DIR")
+message(STATUS "Building ${CMAKE_PROJECT_NAME} GIT SHA1: ${GIT_SHA1}")
+
if(WIN32)
set(${PROJECT}_AUDIOS "OAL" "MSS")
else()