summaryrefslogtreecommitdiffstats
path: root/rust/wolfree_sed_in_place/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/wolfree_sed_in_place/Cargo.toml')
-rw-r--r--rust/wolfree_sed_in_place/Cargo.toml25
1 files changed, 14 insertions, 11 deletions
diff --git a/rust/wolfree_sed_in_place/Cargo.toml b/rust/wolfree_sed_in_place/Cargo.toml
index ab2b32f..0a8bf1d 100644
--- a/rust/wolfree_sed_in_place/Cargo.toml
+++ b/rust/wolfree_sed_in_place/Cargo.toml
@@ -1,21 +1,24 @@
# SPDX-License-Identifier: AGPL-3.0-or-later
-# This file is part of Wolfree.
-# This program is free software: you can redistribute it and/or modify it under the terms of the GNU Affero General Public License as published by the Free Software Foundation, either version 3 of the License, or (at your option) any later version.
[package]
name = "wolfree_sed_in_place"
-version = "23.7.31"
+version = "2023.8.31"
+authors = [
+ "See the commit history of the Git repositories.",
+ "https://git.kiwifarms.net/wolfree",
+]
+categories = [
+ "command-line-utilities",
+ "development-tools::build-utils",
+ "web-programming",
+ "template-engine",
+]
edition = "2021"
-
-authors = ["See the commit history of the Git repositories: <https://try.gitea.io/wolfree>"]
-description = "This Rust program performs in-place search and replaces operations on all files within specified directories. It uses regular expressions to find occurrences of a given pattern in each file's contents and replaces them with the replacement text."
+keywords = ["rust", "search", "replace", "regular expressions", "regex", "file"]
license = "AGPL-3.0-or-later"
-repository = "https://try.gitea.io/wolfree"
readme = "README.md"
-keywords = ["rust", "search", "replace", "regular expressions", "regex", "file", "in-place"]
-categories = ["command-line-utilities", "development-tools::build-utils", "web-programming", "template-engine"]
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+repository = "https://git.kiwifarms.net/wolfree"
+description = "Perform in-place search and replaces operations on all files within specified directories."
[dependencies]
regex = "1"