summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorarchshift <admin@archshift.com>2014-09-03 08:32:15 +0200
committerarchshift <admin@archshift.com>2014-09-03 08:32:15 +0200
commit051b162add564dcc6f86be781df8d951a96a8015 (patch)
treed2f7820e7395aca9622a6093a9cdbbf3114490bb /CMakeLists.txt
parentMerge pull request #69 from yuriks/cmake-cleanup (diff)
downloadyuzu-051b162add564dcc6f86be781df8d951a96a8015.tar
yuzu-051b162add564dcc6f86be781df8d951a96a8015.tar.gz
yuzu-051b162add564dcc6f86be781df8d951a96a8015.tar.bz2
yuzu-051b162add564dcc6f86be781df8d951a96a8015.tar.lz
yuzu-051b162add564dcc6f86be781df8d951a96a8015.tar.xz
yuzu-051b162add564dcc6f86be781df8d951a96a8015.tar.zst
yuzu-051b162add564dcc6f86be781df8d951a96a8015.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e1614cd4a..83b0863f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,7 +65,10 @@ if (ENABLE_GLFW)
set(GLFW_LIBRARIES glfw3)
else()
- find_package(X11 REQUIRED)
+ if (NOT APPLE)
+ find_package(X11 REQUIRED)
+ endif()
+
find_package(PkgConfig REQUIRED)
pkg_search_module(GLFW REQUIRED glfw3)
endif()